summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2023-10-29 11:21:01 +0100
committerEric Woudstra2023-10-29 11:21:01 +0100
commitc8c51fbac001396b15911936779ec6c93bbd1b41 (patch)
tree6b90a32a35c07fde1d7ad2ab8b1d403ebb4b663f
parenta145be8f6275744c9b83c2129003018c85cd8288 (diff)
downloadaur-c8c51fbac001396b15911936779ec6c93bbd1b41.tar.gz
fix remove error
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4d8ab8c5bba..918bb6fad9ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bpir64-git
pkgver = 6.3.9.bpi
- pkgrel = 5
+ pkgrel = 6
url = http://www.kernel.org/
arch = aarch64
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = linux-bpir64-git
makedepends = inetutils
makedepends = bc
makedepends = git
+ makedepends = aarch64-linux-gnu-gcc
options = !strip
source = defconfig
source = linux.preset
diff --git a/PKGBUILD b/PKGBUILD
index fed7920ac379..74a3d907a798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -155,7 +155,7 @@ _package() {
install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modules/${_extramodules}/version"
# remove build and source links
- rm "${pkgdir}"/usr/lib/modules/${_kernver}/{source,build}
+ rm -f "${pkgdir}"/usr/lib/modules/${_kernver}/{source,build}
# now we call depmod...
depmod -b "${pkgdir}/usr" -F System.map "${_kernver}"