summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-12-08 17:15:17 +0100
committerPiotr Gorski2023-12-08 17:15:17 +0100
commit0779e6f82fbbc1b35566c3a349afa0764ef7f3aa (patch)
treefc62ae48f50d0d7ed896fc31ef90dfa5f8a6a886
parentaef5f933a1b593d4641c78f4ec5eabbbf74202ec (diff)
downloadaur-0779e6f82fbbc1b35566c3a349afa0764ef7f3aa.tar.gz
Bump to 6.6.5
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD44
2 files changed, 9 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09570222ee62..57ea48142e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cachyos
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.6.4
+ pkgver = 6.6.5
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -22,16 +22,16 @@ pkgbase = linux-cachyos
makedepends = patch
makedepends = python
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.4.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.5.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.6/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.6/sched/0001-bore-cachy.patch
- b2sums = 75f20de7474f45966a32f7a1e5f9beadb2b4e111fe9c0ab769ccaa203e798f1a1b0ee05c3cb14de6bb609e2e9df1e238deeadfc21dbf08c6b407c9530bac11ef
+ b2sums = 9d66d720f2f037cfd480835ab38807fe5aabcff09bd210c5cb0dc80bd3e1182434df9f04a286df4e8cbc508ac984ecba12d2098a3296e3aac60afad94c085876
b2sums = 5ddb5dcdb79354268e69d01523f06d5071538ba53171adcef0dd455b286df7785611d64f13b3aae06ac298cc60d990ebfa7b11d75dec9ab4a256b431de549483
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
- b2sums = 0b81c9b2746171663a0570f240acbf40b9719f4f7b7bd4ea0e6a6da8901e24e2baba6e36f3422f319b199056184973bcf29321967c0b17745e65307f52a755e6
- b2sums = f2a1f07bc56f26ae3b361c401cbc41ca9927808e52228428d3ed5f909fa8c5231a8760223b3f1480fe9c6d6167825fd4825a66c2ae2411019b57f6aee2585417
+ b2sums = 96ab8ee123335565195fcb5a5e3448d01cd15da64002b321ee88f71c0f826913a7c8bf17bc46a49aaa5eef526b39bf589769a4590dac229621044f58833e5d07
+ b2sums = a9ac9281babe991c49eaf3f55dbe27edd5647d2b9f98f7ef589f1eaace63453e964e188ea9983b7d2324c63e6f1fb5b6408393bb297069e135a501c83ae9920f
pkgname = linux-cachyos
pkgdesc = The Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index a3ee20250316..4d78ac09f497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -170,7 +170,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.6
-_minor=4
+_minor=5
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -197,9 +197,6 @@ if [[ "$_use_llvm_lto" = "thin" || "$_use_llvm_lto" = "full" ]] || [ -n "$_use_k
LLVM_IAS=1
)
fi
-if [ "$_cpusched" = "sched-ext" ]; then
- makedepends+=(clang llvm lld bpf libbpf rust)
-fi
_patchsource="https://raw.githubusercontent.com/cachyos/kernel-patches/master/${_major}"
_nv_ver=545.29.06
@@ -443,14 +440,6 @@ prepare() {
-e TCP_CONG_BBR \
-e DEFAULT_BBR \
--set-str DEFAULT_TCP_CONG bbr
-
- # BBR3 doesn't work properly with FQ_CODEL
- echo "Disabling fq_codel by default..."
- scripts/config -m NET_SCH_FQ_CODEL \
- -e NET_SCH_FQ \
- -d DEFAULT_FQ_CODEL \
- -e DEFAULT_FQ \
- --set-str DEFAULT_NET_SCH fq
fi
### Select LRU config
@@ -688,13 +677,6 @@ build() {
make ${BUILD_FLAGS[*]}
fi
- if [ "$_cpusched" = "sched-ext" ]; then
- # Build the sched_ext schedulers
- cd "$srcdir/$_srcname/tools/sched_ext"
- unset CFLAGS
- unset CXXFLAGS
- make CC=clang LLVM=1 -j
- fi
}
_package() {
@@ -835,27 +817,9 @@ _package-nvidia(){
find "$pkgdir" -name '*.ko' -exec zstd --rm -10 {} +
}
-_package-schedulers() {
- pkgdesc="Schedulers for $pkgdesc kernel"
- depends=('libbpf' 'bpf' 'clang')
-
- cd "$srcdir/$_srcname/tools/sched_ext/build/bin"
-
- install -Dm755 scx_central "$pkgdir"/usr/bin/scx_central
- install -Dm755 scx_flatcg "$pkgdir"/usr/bin/scx_flatcg
- install -Dm755 scx_layered "$pkgdir"/usr/bin/scx_layered
- install -Dm755 scx_nest "$pkgdir"/usr/bin/scx_nest
- install -Dm755 scx_pair "$pkgdir"/usr/bin/scx_pair
- install -Dm755 scx_qmap "$pkgdir"/usr/bin/scx_qmap
- install -Dm755 scx_rusty "$pkgdir"/usr/bin/scx_rusty
- install -Dm755 scx_simple "$pkgdir"/usr/bin/scx_simple
- install -Dm755 scx_userland "$pkgdir"/usr/bin/scx_userland
-}
-
pkgname=("$pkgbase" "$pkgbase-headers")
[ -n "$_build_zfs" ] && pkgname+=("$pkgbase-zfs")
[ -n "$_build_nvidia" ] && pkgname+=("$pkgbase-nvidia")
-[ "$_cpusched" = "sched-ext" ] && pkgname+=("$pkgbase-schedulers")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")
@@ -863,8 +827,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('75f20de7474f45966a32f7a1e5f9beadb2b4e111fe9c0ab769ccaa203e798f1a1b0ee05c3cb14de6bb609e2e9df1e238deeadfc21dbf08c6b407c9530bac11ef'
+b2sums=('9d66d720f2f037cfd480835ab38807fe5aabcff09bd210c5cb0dc80bd3e1182434df9f04a286df4e8cbc508ac984ecba12d2098a3296e3aac60afad94c085876'
'5ddb5dcdb79354268e69d01523f06d5071538ba53171adcef0dd455b286df7785611d64f13b3aae06ac298cc60d990ebfa7b11d75dec9ab4a256b431de549483'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- '0b81c9b2746171663a0570f240acbf40b9719f4f7b7bd4ea0e6a6da8901e24e2baba6e36f3422f319b199056184973bcf29321967c0b17745e65307f52a755e6'
- 'f2a1f07bc56f26ae3b361c401cbc41ca9927808e52228428d3ed5f909fa8c5231a8760223b3f1480fe9c6d6167825fd4825a66c2ae2411019b57f6aee2585417')
+ '96ab8ee123335565195fcb5a5e3448d01cd15da64002b321ee88f71c0f826913a7c8bf17bc46a49aaa5eef526b39bf589769a4590dac229621044f58833e5d07'
+ 'a9ac9281babe991c49eaf3f55dbe27edd5647d2b9f98f7ef589f1eaace63453e964e188ea9983b7d2324c63e6f1fb5b6408393bb297069e135a501c83ae9920f')