summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-11-01 11:53:06 +0100
committerPiotr Gorski2023-11-01 11:53:06 +0100
commit4f6599e43ba938236a5797de1a49eebe5b391002 (patch)
tree4f2e1d91c5768b67c4aa23bbe0213f0ca0437cfa
parent1f97e1e69a88ac1d12ede8c7394244ac5feafa2e (diff)
downloadaur-4f6599e43ba938236a5797de1a49eebe5b391002.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 161160ec4074..0f48d4c90806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -297,6 +297,12 @@ prepare() {
_die "ZFS and bcachefs support cannot be built at the same time. "
fi
+ ### Prevent ZFS and LTO building at the same time
+ # More infos here: https://github.com/openzfs/zfs/issues/15384
+ if [[ "$_use_llvm_lto" != "none" && -n "$_build_zfs" ]]; then
+ _die "ZFS and LTO support cannot be built at the same time. "
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."
@@ -666,7 +672,7 @@ build() {
make ${BUILD_FLAGS[*]} ${MODULE_FLAGS[*]} -j$(nproc) modules
fi
- if [ -n "$_build_zfs" ]; then
+ if [[ "$_cpusched" != "rt" && -n "$_build_zfs" ]]; then
cd ${srcdir}/"zfs"
local CONFIGURE_FLAGS=()