summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-11 19:07:15 +0200
committerPiotr Gorski2023-08-11 19:07:15 +0200
commit711c6473b07aa0bc4966443bceabf52cda320c88 (patch)
tree5cad9eb9233e3ae0e010545fba9a05e385af33de
parent9a4e6ca71e766da9f9c76f7cfa46a83f9661916c (diff)
downloadaur-711c6473b07aa0bc4966443bceabf52cda320c88.tar.gz
Bump to 6.4.10-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--config2
3 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef8d0c0ca27a..5b0ada2519c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cachyos
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 6.4.9
+ pkgver = 6.4.10
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -22,16 +22,16 @@ pkgbase = linux-cachyos
makedepends = patch
makedepends = python
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.9.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.10.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/sched/0001-EEVDF.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.4/sched/0001-bore-eevdf.patch
- b2sums = 87a05cae7d5dca89921801f69467ec01a871941f5dd1bd956bc9f13c4786b35a141811808b36e45471ee3bbe15d669d7114257759f3e5893d17ca38e40ebdc4b
- b2sums = 846bb768495e38acc46c6777f5d15329d2f033968b9380fe5966b52aefc35b098ce57b9d2ab606294b4f675b53def2989e566d4d3ee4a5d68bcd818a9c7fb1af
+ b2sums = 700017448073f63880739efed3f60baba18116500737419e305b2b5e0d2532e2d40a41368c773772cba437236bc1edda85c8f16ca23a945c754e283a30184a6d
+ b2sums = cd383af01fcba36732f3be5bce46b8a809bf29390025418bb37bd188f7a97845185f6e84b313244147ad9c006c2edaf4b108866224b77221d28086cf3f9009cf
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
- b2sums = 9961361f254d189f3b3bffa1276d19e4a1ba8f10454c247582469ee60ca3591f16f709ad1c51d60dafb799c5370f5d6818a5978264903e6517499cf3527aa04b
+ b2sums = 3ec64cda731868642c3e502e09991d2b30779e1fb6194e00b2a3fbfc9516c8cf3f86c1c3475c5fa11a2e71e208748d4c693b688c7fd20690486ad28a61111f0e
b2sums = 11d5923512051c46477aab7ceddaa1fef962c8d503975e34e660acb1a9c7040b147a935ca3f6f5f7e5cadb37e32a1cd25ddd8fda00c403d6364f9612ceebdc1f
b2sums = 893d96b3f582a753cd9821ee78028ef923fbf1c46f45c1c26f76ec02715ae89cdd536c1ebf95d54fb4d4ef4da4f1560f6e6136fd528489f703e41950c03a6dc3
diff --git a/PKGBUILD b/PKGBUILD
index 57f1d6e5e34f..1d56f7d3993f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -168,7 +168,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=6.4
-_minor=9
+_minor=10
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -178,7 +178,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -200,7 +200,7 @@ source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
"config"
"auto-cpu-optimization.sh"
- "${_patchsource}/all/0001-cachyos-base-all-dev.patch")
+ "${_patchsource}/all/0001-cachyos-base-all.patch")
# ZFS support
if [ -n "$_build_zfs" ]; then
@@ -286,13 +286,6 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
- ### Disabling CONFIG_CPU_SRSO for LTO kernel
- # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
- if [ "$_use_llvm_lto" != "none" ]; then
- echo "Disabling CONFIG_CPU_SRSO for LTO kernel..."
- scripts/config -d CPU_SRSO
- fi
-
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."
@@ -796,9 +789,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('87a05cae7d5dca89921801f69467ec01a871941f5dd1bd956bc9f13c4786b35a141811808b36e45471ee3bbe15d669d7114257759f3e5893d17ca38e40ebdc4b'
- 'f86d5bc428a0a3213b186fc16e05779256f243b097b37e69af10b4cce29a9fbcd5b4458b057a86a9aaf12659da7c44df711844cb3beda3f995aa2c2fe7435f17'
+b2sums=('700017448073f63880739efed3f60baba18116500737419e305b2b5e0d2532e2d40a41368c773772cba437236bc1edda85c8f16ca23a945c754e283a30184a6d'
+ 'cd383af01fcba36732f3be5bce46b8a809bf29390025418bb37bd188f7a97845185f6e84b313244147ad9c006c2edaf4b108866224b77221d28086cf3f9009cf'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- '1efda7a89a298b3c4a697fab1c21ab306c1e1f6d173c2726d294b3e9bf6d3c431a45f0e8308484d96aed8364756b71e3da6dc4506b40f32a6c92538a3f675481'
+ '3ec64cda731868642c3e502e09991d2b30779e1fb6194e00b2a3fbfc9516c8cf3f86c1c3475c5fa11a2e71e208748d4c693b688c7fd20690486ad28a61111f0e'
'11d5923512051c46477aab7ceddaa1fef962c8d503975e34e660acb1a9c7040b147a935ca3f6f5f7e5cadb37e32a1cd25ddd8fda00c403d6364f9612ceebdc1f'
'893d96b3f582a753cd9821ee78028ef923fbf1c46f45c1c26f76ec02715ae89cdd536c1ebf95d54fb4d4ef4da4f1560f6e6136fd528489f703e41950c03a6dc3')
diff --git a/config b/config
index b3c0834fd49c..214625c440ed 100644
--- a/config
+++ b/config
@@ -2394,7 +2394,7 @@ CONFIG_ISCSI_IBFT=m
CONFIG_FW_CFG_SYSFS=m
# CONFIG_FW_CFG_SYSFS_CMDLINE is not set
CONFIG_SYSFB=y
-# CONFIG_SYSFB_SIMPLEFB is not set
+CONFIG_SYSFB_SIMPLEFB=y
CONFIG_FW_CS_DSP=m
CONFIG_GOOGLE_FIRMWARE=y
# CONFIG_GOOGLE_SMI is not set