summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-11-15 16:47:51 +0100
committerPiotr Gorski2022-11-15 16:47:51 +0100
commitcad5c8846aad0573e3069c9a32033247c6c3983e (patch)
tree983b7dfac8f5baa108c0e5e444ca5b3a62ba9275
parent18f52f7b2c97e7a1913894071c863f93c893ddae (diff)
downloadaur-cad5c8846aad0573e3069c9a32033247c6c3983e.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9acf529b8c05..eb4158c27bf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,8 +33,8 @@ pkgbase = linux-cachyos
sha256sums = 34e2cad286f32d8c1c26e4ff18726c9e0aee151e82088bb78c3ae4fb536bf962
sha256sums = e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e
sha256sums = 10dac695fc3cd2bf576fe442ab7a4daf0152ca998955ddd6ec0268d1773cc19d
- sha256sums = 941ecb1d26937ef2b69f834cb9a98c2f7cb347f311fd2ecbad668f29ab1571a3
- sha256sums = 8ffd753510273686ee8944ae2c43c96650e3fead435228625d8264ba0227b06a
+ sha256sums = 1ce957095ac2c99d2843f77b3c48b1d818ba71bfbcfb3672e6364306dc1f593b
+ sha256sums = 14fd5588b7bb3d0b00391923c1d46e03b9993837d5348615d006267528dff10c
pkgname = linux-cachyos
pkgdesc = The Linux BORE scheduler Kernel by CachyOS with other patches and improvements kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index 3b61e60b784a..e5a931939981 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,10 @@ _cachy_config=${_cachy_config-'yes'}
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
_cpusched=${_cpusched-'bore'}
+## Apply some suggested sysctl values from the bore developer
+## These are adjusted to BORE
+_tune_bore=${_tune_bore-}
+
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
@@ -251,9 +255,13 @@ fi
if [ "$_cpusched" = "pds" ]; then
source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
fi
-## BORE Scheduler
+## BORE Scheduler with latency_nice
if [ "$_cpusched" = "bore" ]; then
source+=("${_patchsource}/sched/0001-bore-cachy.patch")
+## BORE SYSCTL TUNING
+ if [ -n "$_tune_bore" ]; then
+ source+=("${_patchsource}/misc/0001-bore-tuning-sysctl.patch")
+ fi
fi
## CacULE Scheduler
if [ "$_cpusched" = "cacule" ]; then
@@ -1033,5 +1041,5 @@ sha256sums=('0de4f83996951c6faf9b2225db4f645882c47b1a09198190f97bd46e5f5fa257'
'34e2cad286f32d8c1c26e4ff18726c9e0aee151e82088bb78c3ae4fb536bf962'
'e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e'
'10dac695fc3cd2bf576fe442ab7a4daf0152ca998955ddd6ec0268d1773cc19d'
- '941ecb1d26937ef2b69f834cb9a98c2f7cb347f311fd2ecbad668f29ab1571a3'
- '8ffd753510273686ee8944ae2c43c96650e3fead435228625d8264ba0227b06a')
+ '1ce957095ac2c99d2843f77b3c48b1d818ba71bfbcfb3672e6364306dc1f593b'
+ '14fd5588b7bb3d0b00391923c1d46e03b9993837d5348615d006267528dff10c')