summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2024-01-31 19:49:36 +0100
committerPiotr Gorski2024-01-31 19:49:36 +0100
commit1249403a645614198e64e39d80ccf76926f940b4 (patch)
treed68adfbcaab3dd3596ed2d81c944b32e6353927c
parent2a688eaf523db3f996a1f8ecb3da9016ea15e32b (diff)
downloadaur-1249403a645614198e64e39d80ccf76926f940b4.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--config6
3 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef31974e9c77..78878a66dc11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cachyos-bore
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements
pkgver = 6.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -28,7 +28,7 @@ pkgbase = linux-cachyos-bore
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.7/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.7/sched/0001-bore-cachy.patch
b2sums = 4c1f480de0c1458aa67379cd02d35708f63850adb84a85061088de1f82b5d084bc7cf7da459a3f1e415544351d1f36a9a832277240774ae461cdde11687cbadd
- b2sums = 9c7b52c103a8506c027a28e81779ecba972f3c85f8917359282a6183d04d04407950ba55d3db13b285b722aafb68f308b16733e575e6b2f6e77b08682c7e5dc4
+ b2sums = 1da8ae554a57e2c2ecbc2bce091a8f27f2f8403b63a4c38f0c1df0b1607de67abbe99ba5fcb87a246a46e925b762865adc092bf18c7317d5b19e58087d787491
b2sums = 43ef7a347878592740d9eb23b40a56083fa747f7700fa1e2c6d039d660c0b876d99bf1a3160e15d041fb13d45906cdb5defef034d4d0ae429911864239c94d8d
b2sums = a89904cd7c7248ca97ace716330d76950edcbbbc9b9fb36e46841914c1ab6f0ec16549d308846b89b16df1943c652977983632808da59d8596fbe12e9e9e3f9f
b2sums = 95bae7723f6837b86f8897a006a7d191f56a10b9b6797f8d5f89388e4a5038c6d9cf4072d44e7e6fcd720d0270765f44fdc37f955dd43c29454cd86be022e64a
diff --git a/PKGBUILD b/PKGBUILD
index 6591b8ac0bdf..1d74c036ec24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -174,7 +174,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -224,9 +224,8 @@ fi
## List of CachyOS schedulers
case "$_cpusched" in
- cachyos) # CachyOS Scheduler (BORE + SCHED-EXT)
- source+=("${_patchsource}/sched/0001-sched-ext.patch"
- "${_patchsource}/sched/0001-bore-cachy.patch");;
+ cachyos|sched-ext) ## SCHED-EXT
+ source+=("${_patchsource}/sched/0001-sched-ext.patch");;
bore) ## BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch");;
rt) ## EEVDF with RT patches
@@ -239,15 +238,8 @@ case "$_cpusched" in
hardened) ## Hardened Patches with BORE Scheduler
source+=("${_patchsource}/sched/0001-bore-cachy.patch"
"${_patchsource}/misc/0001-hardened.patch");;
- sched-ext) ## SCHED-EXT
- source+=("${_patchsource}/sched/0001-sched-ext.patch");;
esac
-# BORE Tuning Sysctl
-if [ -n "$_bore_tuning_sysctl" ]; then
- source+=("${_patchsource}/misc/bore-tuning-sysctl.patch")
-fi
-
## lrng patchset
if [ -n "$_lrng_enable" ]; then
source+=("${_patchsource}/misc/0001-lrng.patch")
@@ -304,12 +296,11 @@ prepare() {
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
case "$_cpusched" in
- cachyos) scripts/config -e SCHED_BORE -e SCHED_CLASS_EXT;;
+ cachyos|sched-ext) scripts/config -e SCHED_CLASS_EXT;;
bore|hardened) scripts/config -e SCHED_BORE;;
eevdf) ;;
rt) scripts/config -e PREEMPT_COUNT -e PREEMPTION -d PREEMPT_VOLUNTARY -d PREEMPT -d PREEMPT_NONE -e PREEMPT_RT -d PREEMPT_DYNAMIC -d PREEMPT_BUILD;;
rt-bore) scripts/config -e SCHED_BORE -e PREEMPT_COUNT -e PREEMPTION -d PREEMPT_VOLUNTARY -d PREEMPT -d PREEMPT_NONE -e PREEMPT_RT -d PREEMPT_DYNAMIC -d PREEMPT_BUILD;;
- sched-ext) scripts/config -e SCHED_CLASS_EXT;;
*) _die "The value $_cpusched is invalid. Choose the correct one again.";;
esac
@@ -826,7 +817,7 @@ for _p in "${pkgname[@]}"; do
done
b2sums=('4c1f480de0c1458aa67379cd02d35708f63850adb84a85061088de1f82b5d084bc7cf7da459a3f1e415544351d1f36a9a832277240774ae461cdde11687cbadd'
- '9c7b52c103a8506c027a28e81779ecba972f3c85f8917359282a6183d04d04407950ba55d3db13b285b722aafb68f308b16733e575e6b2f6e77b08682c7e5dc4'
+ '1da8ae554a57e2c2ecbc2bce091a8f27f2f8403b63a4c38f0c1df0b1607de67abbe99ba5fcb87a246a46e925b762865adc092bf18c7317d5b19e58087d787491'
'43ef7a347878592740d9eb23b40a56083fa747f7700fa1e2c6d039d660c0b876d99bf1a3160e15d041fb13d45906cdb5defef034d4d0ae429911864239c94d8d'
'a89904cd7c7248ca97ace716330d76950edcbbbc9b9fb36e46841914c1ab6f0ec16549d308846b89b16df1943c652977983632808da59d8596fbe12e9e9e3f9f'
'95bae7723f6837b86f8897a006a7d191f56a10b9b6797f8d5f89388e4a5038c6d9cf4072d44e7e6fcd720d0270765f44fdc37f955dd43c29454cd86be022e64a')
diff --git a/config b/config
index 4a7a087fae62..1cbd4335affc 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.7.1 Kernel Configuration
+# Linux/x86 6.7.2 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.2.1 20231110"
CONFIG_CC_IS_GCC=y
@@ -7381,7 +7381,6 @@ CONFIG_SND_DESIGNWARE_PCM=y
# CONFIG_SND_SOC_FSL_ESAI is not set
# CONFIG_SND_SOC_FSL_MICFIL is not set
CONFIG_SND_SOC_FSL_XCVR=m
-CONFIG_SND_SOC_FSL_RPMSG=m
# CONFIG_SND_SOC_IMX_AUDMUX is not set
# end of SoC Audio for Freescale CPUs
@@ -11582,13 +11581,14 @@ CONFIG_DEBUG_LIST=y
CONFIG_RCU_CPU_STALL_TIMEOUT=60
CONFIG_RCU_EXP_CPU_STALL_TIMEOUT=0
# CONFIG_RCU_CPU_STALL_CPUTIME is not set
+# CONFIG_RCU_CPU_STALL_NOTIFIER is not set
# CONFIG_RCU_TRACE is not set
# CONFIG_RCU_EQS_DEBUG is not set
# end of RCU Debugging
# CONFIG_DEBUG_WQ_FORCE_RR_CPU is not set
# CONFIG_CPU_HOTPLUG_STATE_CONTROL is not set
-CONFIG_LATENCYTOP=y
+# CONFIG_LATENCYTOP is not set
# CONFIG_DEBUG_CGROUP_REF is not set
CONFIG_USER_STACKTRACE_SUPPORT=y
CONFIG_NOP_TRACER=y