summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-28 01:20:07 +0200
committerPiotr Gorski2022-09-28 01:20:07 +0200
commit394cdbd0ce46713e9316bad89afd795926e95ab2 (patch)
treedf43576b948e191da8ac6021d5e84a0d4279a0cb
parent9597d19577c11c1ac8df7dbcaea0545bd82b640d (diff)
downloadaur-394cdbd0ce46713e9316bad89afd795926e95ab2.tar.gz
Improve nest and latency nice flags
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0c235d614cf..fb89ab180525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -272,11 +272,15 @@ if [ -n "$_bcachefs" ]; then
fi
## NEST Support
if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
fi
export KBUILD_BUILD_HOST=cachyos