summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-11-15 16:49:41 +0100
committerPiotr Gorski2022-11-15 16:49:41 +0100
commit7670bcf440705fc62f590c40e27027ffe373f24f (patch)
tree28a537455703efc091b9fffa6ea6f7a6655e8307
parent79c7254155c39bcb7a7a3451492896819592193b (diff)
downloadaur-7670bcf440705fc62f590c40e27027ffe373f24f.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c67e5533954..59e031d95977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,10 @@ _cachy_config=${_cachy_config-'yes'}
# 'hardened' - select 'BORE Scheduler hardened' ## kernel with hardened config and hardening patches with the bore scheduler
_cpusched=${_cpusched-'cacule'}
+## Apply some suggested sysctl values from the bore developer
+## These are adjusted to BORE
+_tune_bore=${_tune_bore-}
+
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
@@ -251,9 +255,13 @@ fi
if [ "$_cpusched" = "pds" ]; then
source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
fi
-## BORE Scheduler
+## BORE Scheduler with latency_nice
if [ "$_cpusched" = "bore" ]; then
source+=("${_patchsource}/sched/0001-bore-cachy.patch")
+## BORE SYSCTL TUNING
+ if [ -n "$_tune_bore" ]; then
+ source+=("${_patchsource}/misc/0001-bore-tuning-sysctl.patch")
+ fi
fi
## CacULE Scheduler
if [ "$_cpusched" = "cacule" ]; then