summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-25 00:05:17 +0200
committerPiotr Gorski2022-09-25 00:05:17 +0200
commit9597d19577c11c1ac8df7dbcaea0545bd82b640d (patch)
tree7f5dbdce984f42d9b7d9121d14c3c04133faacd0
parentfec26db39dc5575c79d6c9a54ce60f0f1c4f30a2 (diff)
downloadaur-9597d19577c11c1ac8df7dbcaea0545bd82b640d.tar.gz
Bump to 5.19.11-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
-rw-r--r--config4
3 files changed, 42 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54eb0a75d96f..0743c700c756 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cachyos-cacule
pkgdesc = Linux cacULE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 5.19.10
- pkgrel = 2
+ pkgver = 5.19.11
+ pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -21,15 +21,15 @@ pkgbase = linux-cachyos-cacule
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.10.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.11.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/sched/0001-cacULE-cachy.patch
- sha256sums = 67dab932e85f9b9062ced666c8ea888230a1dadfd624b05aead6b6ebc6d3bdd5
- sha256sums = 2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b
+ sha256sums = 5554d2f90b806bb3454fcf3432882cf85077d660a89db5a4e8d7375271e3d973
+ sha256sums = c4543a2528981a6c4be7b368f3648995823ab9a1060afd7b51d06c9d377ad7fa
sha256sums = e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e
- sha256sums = 37b05cf8cbefcc7660a548916ceba53adab153ef1202f49f465d02221fd4fa62
+ sha256sums = e8c5da2bac99834d059d0514dd751553dec4884ced222b871e13e1b98a6cc39a
sha256sums = a8f6c086e4232071b692d1f696a3e9c356c8f44d1b11acce05632a75c727ac4d
pkgname = linux-cachyos-cacule
diff --git a/PKGBUILD b/PKGBUILD
index 87bb27d44557..f0c235d614cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -155,6 +155,27 @@ _build_zfs=
# Enable bcachefs
_bcachefs=
+# Enable NEST
+# NEST is a experimental cfs scheduler you can find more about here:
+# https://www.phoronix.com/news/Nest-Linux-Scheduling-Warm-Core
+# https://gitlab.inria.fr/nest-public/nest-artifact/-/tree/main
+# ATTENTION!:NEST is only active if you start applications with
+# taskset -c $THREADS application
+# example: taskset -c 0-23 application
+# ATTENTION!:Just works together with the BORE Scheduler and CFS Scheduler
+_nest=
+
+# Enable LATENCY NICE
+# Latency nice is a approach to sets latency-nice as a per-task attribute
+# It can improve the latency of applications similar to sched_nice, but focused on the latency
+# You need to set the values per task
+# Ananicy-cpp has a experimental implementation for this
+# It converts sched_nice to latency_nice and set this per task
+# You need to configure ananicy-cpp for this or use existing settings
+# If you want to test it, use the following branch
+# https://gitlab.com/ananicy-cpp/ananicy-cpp/-/tree/feature/latency-nice
+_latency_nice=
+
if [ -n "$_use_llvm_lto" ]; then
pkgsuffix=cachyos-${_cpusched}-lto
pkgbase=linux-$pkgsuffix
@@ -164,7 +185,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=5.19
-_minor=10
+_minor=11
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -174,7 +195,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -249,6 +270,14 @@ fi
if [ -n "$_bcachefs" ]; then
source+=("${_patchsource}/misc/0001-bcachefs-after-lru.patch")
fi
+## NEST Support
+if [ -n "$_nest" ]; then
+ source+=("${_patchsource}/sched/0001-NEST.patch")
+fi
+## Latency NICE Support
+if [ -n "$_latency_nice" ]; then
+ source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+fi
export KBUILD_BUILD_HOST=cachyos
export KBUILD_BUILD_USER=$pkgbase
@@ -966,8 +995,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('67dab932e85f9b9062ced666c8ea888230a1dadfd624b05aead6b6ebc6d3bdd5'
- '2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b'
+sha256sums=('5554d2f90b806bb3454fcf3432882cf85077d660a89db5a4e8d7375271e3d973'
+ 'c4543a2528981a6c4be7b368f3648995823ab9a1060afd7b51d06c9d377ad7fa'
'e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e'
- '37b05cf8cbefcc7660a548916ceba53adab153ef1202f49f465d02221fd4fa62'
+ 'e8c5da2bac99834d059d0514dd751553dec4884ced222b871e13e1b98a6cc39a'
'a8f6c086e4232071b692d1f696a3e9c356c8f44d1b11acce05632a75c727ac4d')
diff --git a/config b/config
index 064a28978c27..e9624539b9e8 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.19.9 Kernel Configuration
+# Linux/x86 5.19.11 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -3057,7 +3057,7 @@ CONFIG_DM_UEVENT=y
CONFIG_DM_FLAKEY=m
CONFIG_DM_VERITY=m
CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG=y
-# CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG_SECONDARY_KEYRING is not set
+CONFIG_DM_VERITY_VERIFY_ROOTHASH_SIG_SECONDARY_KEYRING=y
CONFIG_DM_VERITY_FEC=y
CONFIG_DM_SWITCH=m
CONFIG_DM_LOG_WRITES=m