summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-15 17:06:23 +0200
committerPiotr Gorski2022-09-15 17:06:23 +0200
commita59ba59151eaea13283de88113d63d606853b3d7 (patch)
tree38e1d431d12a5dbfa1b699e518e453277649a559
parent6078a82f074eea7d52daddc77e4121331c374359 (diff)
downloadaur-a59ba59151eaea13283de88113d63d606853b3d7.tar.gz
Improve vma-per-lock flag
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--config4
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31174eb16ecd..9c12613f55de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cachyos-cacule
pkgdesc = Linux cacULE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 5.19.8
+ pkgver = 5.19.9
pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -21,15 +21,15 @@ pkgbase = linux-cachyos-cacule
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.8.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.9.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/sched/0001-cacULE-cachy.patch
- sha256sums = 616308795a952a6a39b4c74807c33916850eb7166d8ed7c9a87a1ba55d7487ce
- sha256sums = 4e00d2c15d104f239fd1b320c0fd00f8de6ef7cb0e1eaba477b8b227854d639e
+ sha256sums = 0ad5b5986693adc1962be807bc3a64423a24b6a9da9df39b259d7e3bfd927f37
+ sha256sums = 2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b
sha256sums = e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e
- sha256sums = 170239dd75f80d5f3c4a4706b11c6569a97be36a9057cd36c54296da0cc6a2d7
+ sha256sums = 85aeec85cfeff447503c7c1f648c82764d22cecc57ce0b33338e7936c8282ee5
sha256sums = 13dc8ec85783b793ddd84472d6baef7154e964dacb179024fc7d0de493059b29
pkgname = linux-cachyos-cacule
diff --git a/PKGBUILD b/PKGBUILD
index c4e821da7e24..f3ff5cb3627f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,9 +85,10 @@ _kyber_disable=y
_lru_config='standard'
### Enable per-VMA locking
-# ATTENTION - one of two predefined values should be selected!
+# ATTENTION - one of three predefined values should be selected!
# 'standard' - enable per-VMA locking
# 'stats' - enable per-VMA locking with stats
+# 'none' - disable per-VMA locking
_vma_config='standard'
## Enable DAMON
@@ -154,7 +155,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=5.19
-_minor=8
+_minor=9
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -539,6 +540,9 @@ prepare() {
echo "Enabling per-VMA locking with stats..."
scripts/config --enable PER_VMA_LOCK \
--enable PER_VMA_LOCK_STATS
+ elif [ "$_vma_config" = "none" ]; then
+ echo "Disabling per-VMA locking..."
+ scripts/config --disable PER_VMA_LOCK
else
if [ -n "$_vma_config" ]; then
error "The value $_vma_config is invalid. Choose the correct one again."
@@ -909,8 +913,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('616308795a952a6a39b4c74807c33916850eb7166d8ed7c9a87a1ba55d7487ce'
- '4e00d2c15d104f239fd1b320c0fd00f8de6ef7cb0e1eaba477b8b227854d639e'
+sha256sums=('0ad5b5986693adc1962be807bc3a64423a24b6a9da9df39b259d7e3bfd927f37'
+ '2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b'
'e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e'
- '170239dd75f80d5f3c4a4706b11c6569a97be36a9057cd36c54296da0cc6a2d7'
+ '85aeec85cfeff447503c7c1f648c82764d22cecc57ce0b33338e7936c8282ee5'
'13dc8ec85783b793ddd84472d6baef7154e964dacb179024fc7d0de493059b29')
diff --git a/config b/config
index b83e9bd838b0..064a28978c27 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.19.8 Kernel Configuration
+# Linux/x86 5.19.9 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -1197,7 +1197,7 @@ CONFIG_PTE_MARKER_UFFD_WP=y
# CONFIG_LRU_GEN_ENABLED is not set
# CONFIG_LRU_GEN_STATS is not set
CONFIG_ARCH_SUPPORTS_PER_VMA_LOCK=y
-CONFIG_PER_VMA_LOCK=y
+# CONFIG_PER_VMA_LOCK is not set
#
# Data Access Monitoring