summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-15 20:50:41 +0200
committerPiotr Gorski2022-09-15 20:50:41 +0200
commitad120db9d96205646ae158c5338dc65e1cfda480 (patch)
tree511a057fb3640ed912e8496a46c176c99333486d
parenta59ba59151eaea13283de88113d63d606853b3d7 (diff)
downloadaur-ad120db9d96205646ae158c5338dc65e1cfda480.tar.gz
Add cachyos config flag
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3ff5cb3627f..97851b20f58c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,12 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
+### Selecting CachyOS config
+# ATTENTION - one of two predefined values should be selected!
+# 'yes' - enable CachyOS config
+# 'no' - disable CachyOS config
+_cachy_config='yes'
+
### Selecting the CPU scheduler
# ATTENTION - one of seven predefined values should be selected!
# 'bmq' - select 'BitMap Queue CPU scheduler'
@@ -279,6 +285,23 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Selecting CachyOS config
+ if [ "$_cachy_config" = "yes" ]; then
+ echo "Enabling CachyOS config..."
+ scripts/config --enable CACHY_CONFIG
+ elif [ "$_cachy_config" = "no" ]; then
+ echo "Disabling CachyOS config..."
+ scripts/config --disable CACHY_CONFIG
+ else
+ if [ -n "$_cachy_config" ]; then
+ error "The value $_cachy_config is invalid. Choose the correct one again."
+ else
+ error "The value is empty. Choose the correct one again."
+ fi
+ error "Selecting CachyOS config failed!"
+ exit
+ fi
+
### Selecting the CPU scheduler
if [ "$_cpusched" = "bmq" ]; then
echo "Selecting BMQ CPU scheduler..."