summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-10 11:10:49 +0200
committerPiotr Gorski2023-08-10 11:10:49 +0200
commit8062449ec2dad9a8bb6995ea0083d5d7b56da5a6 (patch)
treeee8d342fdfe70d5166627f052995a0c3a7f72605
parentb771146532a25d30bc1c8272bf16461a85e97ec2 (diff)
downloadaur-8062449ec2dad9a8bb6995ea0083d5d7b56da5a6.tar.gz
Disable CONFIG_CPU_SRSO for thin and full LTO
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b53488cf4e8..a0512a0005d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -286,6 +286,13 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Disabling CONFIG_CPU_SRSO
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
+ if [ "$_use_llvm_lto" != "none" ]; then
+ echo "Disabling CONFIG_CPU_SRSO..."
+ scripts/config -d CPU_SRSO
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."