summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-21 11:11:12 +0200
committerPiotr Gorski2023-08-21 11:11:12 +0200
commit779b0047f6c7626dc5676c2b86ee4051f6b88f50 (patch)
treecb6353c260bec1d7e59746d10060c80dcdfde666
parentcd4f26b542413e84101cc121ba20503927a703c3 (diff)
downloadaur-779b0047f6c7626dc5676c2b86ee4051f6b88f50.tar.gz
Bump to 6.5-rc7
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
-rw-r--r--config10
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b1ea8dff627..0dad20866d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cachyos-rc
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS and with some other patches and other improvements
- pkgver = 6.5.rc6
- pkgrel = 2
+ pkgver = 6.5.rc7
+ pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -22,17 +22,17 @@ pkgbase = linux-cachyos-rc
makedepends = patch
makedepends = python
options = !strip
- source = https://github.com/torvalds/linux/archive/refs/tags/v6.5-rc6.tar.gz
+ source = https://github.com/torvalds/linux/archive/refs/tags/v6.5-rc7.tar.gz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/sched/0001-EEVDF-cachy.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/sched/0001-bore-eevdf.patch
- b2sums = 8623a7cc34057d514f8782ba8da8fbaf514c1978975595272521abdcaeca321aca2c0cab2337f699bf884c78145fde70aab62919b7619369721032087d2b2cd9
- b2sums = d01cf326f583f294dfb78ce0591c3758573c67b07363d41f52a11acf76e06b9c314b2c6e4ddf3aeb199f987173817c90908433bb65f3641e7483f97c99d227bf
+ b2sums = 764c0953ffea3bf728be007132346faba1dd348b1d4685bef523b57dd3d0cd4fb293e6174415d3fe7299e5a1ff722221508182b69bd69191234025e563e468de
+ b2sums = 6f0e176b8d0d0b6fd2bff994191d95a564fbc80c3073c39bda2072260b99dc80cb6dce83a02f86a74155a7377cfccadd59027fe0931e250f12d522cef88b4dd8
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
- b2sums = f85cf380f612c8bde12bc9fa11fb5f0f09c8baf787564f3b1c3846b845d618881bc3e5b2d4cab6d790569f91faa833d9cca7441ec2ec92337c3c295841f6bff5
- b2sums = c6256278570b586d8b2a58b4fc6fe255f5acdc5760c5178b7105672f2c12587fcfe8ae9b9e7e44999fe83d210a779019f563fa06af0e3ba327ed06f73af99cef
+ b2sums = c31b848711974dfe66102e9f95447fae77e183ac6bbd488922a76cc16cfd68644b2d667d755e1d7826a9c9169b976e6d3def61d048908651d7f68080d682d857
+ b2sums = 139e8c81fb7974f7f1c2841d589dbba444dd69dbe701e51e2aa4ccc06166807b823dd239ed9b8e95b64b4470c762b9c5fef82d32d19f75c6afb38c3c1025e3a5
b2sums = eb919edb6a3a82c14264baa6a9347bdd89f864a648b57d1d9652694bbc43dab62922c36170ee07cfb7b44df08a0235ceec8e32e39d393ffc686e346ddfef7fbd
pkgname = linux-cachyos-rc
diff --git a/PKGBUILD b/PKGBUILD
index 8684be8667bc..7526ad663bb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -170,7 +170,7 @@ fi
_major=6.5
_minor=0
#_minorc=$((_minor+1))
-_rcver=rc6
+_rcver=rc7
pkgver=${_major}.${_rcver}
#_stable=${_major}.${_minor}
#_stable=${_major}
@@ -178,7 +178,7 @@ _stable=${_major}-${_rcver}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux EEVDF-BORE scheduler Kernel by CachyOS and with some other patches and other improvements'
-pkgrel=2
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -187,7 +187,7 @@ options=('!strip')
makedepends=('bc' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch' 'python')
# LLVM makedepends
if [[ "$_use_llvm_lto" = "thin" || "$_use_llvm_lto" = "full" ]] || [ -n "$_use_kcfi" ]; then
- makedepends+=(clang llvm lld python)
+ makedepends+=(clang llvm lld)
BUILD_FLAGS=(
CC=clang
LD=ld.lld
@@ -803,9 +803,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('8623a7cc34057d514f8782ba8da8fbaf514c1978975595272521abdcaeca321aca2c0cab2337f699bf884c78145fde70aab62919b7619369721032087d2b2cd9'
- 'd01cf326f583f294dfb78ce0591c3758573c67b07363d41f52a11acf76e06b9c314b2c6e4ddf3aeb199f987173817c90908433bb65f3641e7483f97c99d227bf'
+b2sums=('764c0953ffea3bf728be007132346faba1dd348b1d4685bef523b57dd3d0cd4fb293e6174415d3fe7299e5a1ff722221508182b69bd69191234025e563e468de'
+ '6f0e176b8d0d0b6fd2bff994191d95a564fbc80c3073c39bda2072260b99dc80cb6dce83a02f86a74155a7377cfccadd59027fe0931e250f12d522cef88b4dd8'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- 'f85cf380f612c8bde12bc9fa11fb5f0f09c8baf787564f3b1c3846b845d618881bc3e5b2d4cab6d790569f91faa833d9cca7441ec2ec92337c3c295841f6bff5'
- 'c6256278570b586d8b2a58b4fc6fe255f5acdc5760c5178b7105672f2c12587fcfe8ae9b9e7e44999fe83d210a779019f563fa06af0e3ba327ed06f73af99cef'
+ 'c31b848711974dfe66102e9f95447fae77e183ac6bbd488922a76cc16cfd68644b2d667d755e1d7826a9c9169b976e6d3def61d048908651d7f68080d682d857'
+ '139e8c81fb7974f7f1c2841d589dbba444dd69dbe701e51e2aa4ccc06166807b823dd239ed9b8e95b64b4470c762b9c5fef82d32d19f75c6afb38c3c1025e3a5'
'eb919edb6a3a82c14264baa6a9347bdd89f864a648b57d1d9652694bbc43dab62922c36170ee07cfb7b44df08a0235ceec8e32e39d393ffc686e346ddfef7fbd')
diff --git a/config b/config
index 6b9077942a73..93aa625471fb 100644
--- a/config
+++ b/config
@@ -1,15 +1,15 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.5.0-rc1 Kernel Configuration
+# Linux/x86 6.5.0-rc7 Kernel Configuration
#
-CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.1.1 20230525"
+CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.2.1 20230730"
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=130101
+CONFIG_GCC_VERSION=130201
CONFIG_CLANG_VERSION=0
CONFIG_AS_IS_GNU=y
-CONFIG_AS_VERSION=24000
+CONFIG_AS_VERSION=24100
CONFIG_LD_IS_BFD=y
-CONFIG_LD_VERSION=24000
+CONFIG_LD_VERSION=24100
CONFIG_LLD_VERSION=0
CONFIG_RUST_IS_AVAILABLE=y
CONFIG_CC_CAN_LINK=y