summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-13 23:10:38 +0200
committerPiotr Gorski2023-08-13 23:10:38 +0200
commit8dbfc57c4f2959e7797f698fe183a128af6c8f3b (patch)
tree97e8c31fc919a9632d62d65b86785272f4c1f0c5
parent30df31d02b0408555485d88f1274efa901ed7a8a (diff)
downloadaur-8dbfc57c4f2959e7797f698fe183a128af6c8f3b.tar.gz
Bump to 6.5-rc6
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a1bded04fec..91167ffa925d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cachyos-rc
pkgdesc = Linux EEVDF-BORE scheduler Kernel by CachyOS and with some other patches and other improvements
- pkgver = 6.5.rc4
+ pkgver = 6.5.rc6
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -22,18 +22,18 @@ pkgbase = linux-cachyos-rc
makedepends = patch
makedepends = python
options = !strip
- source = https://github.com/torvalds/linux/archive/refs/tags/v6.5-rc4.tar.gz
+ source = https://github.com/torvalds/linux/archive/refs/tags/v6.5-rc6.tar.gz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/sched/0001-EEVDF-cachy.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/6.5/sched/0001-bore-eevdf.patch
- b2sums = 21530d34bc89c9450ebd348755a357a1455809fd75cdd1db4063d991fc4802293648055ad862a99ea3e65931778cb0811be0981299f0f6d8c1bcf6cec62b7365
+ b2sums = 8623a7cc34057d514f8782ba8da8fbaf514c1978975595272521abdcaeca321aca2c0cab2337f699bf884c78145fde70aab62919b7619369721032087d2b2cd9
b2sums = d01cf326f583f294dfb78ce0591c3758573c67b07363d41f52a11acf76e06b9c314b2c6e4ddf3aeb199f987173817c90908433bb65f3641e7483f97c99d227bf
b2sums = 11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0
- b2sums = a71aade3f9d2aa4e4644c0c17d274b75fa1e5b8c62f00b595648c588d2ddf1adaef7c85d9253d7925b3daf847c2e22d7b9aaaf91ba4a05e103b7937ed404e865
- b2sums = 7fe73d10da6a76bf9d65c4134f1da67478accc0e83ff08c54a308e511679ce63ca34ccbb01282bd9fcab50610a0e9d03575edf1f7c5cc34f23151f15e5b5c00c
- b2sums = 7aae1ea4c389ab84acb53ac006b600a5f0b6936a7482b8f499af0576c3540ad5fbbf184fcd6e5955b620e3151ce806032635d6f16d34065f7cbd13bb7f963f4b
+ b2sums = f85cf380f612c8bde12bc9fa11fb5f0f09c8baf787564f3b1c3846b845d618881bc3e5b2d4cab6d790569f91faa833d9cca7441ec2ec92337c3c295841f6bff5
+ b2sums = c6256278570b586d8b2a58b4fc6fe255f5acdc5760c5178b7105672f2c12587fcfe8ae9b9e7e44999fe83d210a779019f563fa06af0e3ba327ed06f73af99cef
+ b2sums = eb919edb6a3a82c14264baa6a9347bdd89f864a648b57d1d9652694bbc43dab62922c36170ee07cfb7b44df08a0235ceec8e32e39d393ffc686e346ddfef7fbd
pkgname = linux-cachyos-rc
pkgdesc = The Linux EEVDF-BORE scheduler Kernel by CachyOS and with some other patches and other improvements kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index dcb4aca38c79..1ceaea658917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -170,7 +170,7 @@ fi
_major=6.5
_minor=0
#_minorc=$((_minor+1))
-_rcver=rc4
+_rcver=rc6
pkgver=${_major}.${_rcver}
#_stable=${_major}.${_minor}
#_stable=${_major}
@@ -205,7 +205,7 @@ source=(
# ZFS support
if [ -n "$_build_zfs" ]; then
makedepends+=(git)
- source+=("git+https://github.com/cachyos/zfs.git#commit=f9a2d94c957d0660ad1f4cfbb0a909eb8e6086df")
+ source+=("git+https://github.com/cachyos/zfs.git#commit=8e20e0ff39f0492cdc477f15d9d8c1b2f092d562")
fi
case "$_cpusched" in
@@ -286,11 +286,10 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
- ### Disabling CONFIG_CPU_SRSO
- # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
- if [ "$_use_llvm_lto" != "none" ]; then
- echo "Disabling CONFIG_CPU_SRSO..."
- scripts/config -d CPU_SRSO
+ ### Prevent ZFS and bcachefs building at the same time
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/152
+ if [[ -n "$_bcachefs" && -n "$_build_zfs" ]]; then
+ _die "ZFS and bcachefs support cannot be built at the same time. "
fi
### Selecting CachyOS config
@@ -299,6 +298,12 @@ prepare() {
scripts/config -e CACHY
fi
+ ### Workaround for bcachefs
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/152
+ if [ -n "$_bcachefs" ]; then
+ scripts/config -d DRM_ACCEL_IVPU
+ fi
+
### Selecting the CPU scheduler
[ -z "$_cpusched" ] && _die "The value is empty. Choose the correct one again."
@@ -798,9 +803,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-b2sums=('21530d34bc89c9450ebd348755a357a1455809fd75cdd1db4063d991fc4802293648055ad862a99ea3e65931778cb0811be0981299f0f6d8c1bcf6cec62b7365'
+b2sums=('8623a7cc34057d514f8782ba8da8fbaf514c1978975595272521abdcaeca321aca2c0cab2337f699bf884c78145fde70aab62919b7619369721032087d2b2cd9'
'd01cf326f583f294dfb78ce0591c3758573c67b07363d41f52a11acf76e06b9c314b2c6e4ddf3aeb199f987173817c90908433bb65f3641e7483f97c99d227bf'
'11d2003b7d71258c4ca71d71c6b388f00fe9a2ddddc0270e304148396dadfd787a6cac1363934f37d0bfb098c7f5851a02ecb770e9663ffe57ff60746d532bd0'
- 'a71aade3f9d2aa4e4644c0c17d274b75fa1e5b8c62f00b595648c588d2ddf1adaef7c85d9253d7925b3daf847c2e22d7b9aaaf91ba4a05e103b7937ed404e865'
- '7fe73d10da6a76bf9d65c4134f1da67478accc0e83ff08c54a308e511679ce63ca34ccbb01282bd9fcab50610a0e9d03575edf1f7c5cc34f23151f15e5b5c00c'
- '7aae1ea4c389ab84acb53ac006b600a5f0b6936a7482b8f499af0576c3540ad5fbbf184fcd6e5955b620e3151ce806032635d6f16d34065f7cbd13bb7f963f4b')
+ 'f85cf380f612c8bde12bc9fa11fb5f0f09c8baf787564f3b1c3846b845d618881bc3e5b2d4cab6d790569f91faa833d9cca7441ec2ec92337c3c295841f6bff5'
+ 'c6256278570b586d8b2a58b4fc6fe255f5acdc5760c5178b7105672f2c12587fcfe8ae9b9e7e44999fe83d210a779019f563fa06af0e3ba327ed06f73af99cef'
+ 'eb919edb6a3a82c14264baa6a9347bdd89f864a648b57d1d9652694bbc43dab62922c36170ee07cfb7b44df08a0235ceec8e32e39d393ffc686e346ddfef7fbd')