summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-08-10 11:15:00 +0200
committerPiotr Gorski2023-08-10 11:15:00 +0200
commitd494912c587668e82ed4d0678310631a272346b7 (patch)
tree9f0b7a500be0d9a5e40ce98ebe4e402d1b964087
parent53d37ebd2b695ca644d55eeaef83ab7c8a3dd511 (diff)
downloadaur-d494912c587668e82ed4d0678310631a272346b7.tar.gz
Disable CONFIG_CPU_SRSO for thin and full LTO
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c86b2e0f60a5..f13444f986a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -286,6 +286,13 @@ prepare() {
"${srcdir}"/auto-cpu-optimization.sh
fi
+ ### Disabling CONFIG_CPU_SRSO
+ # More infos here: https://github.com/CachyOS/linux-cachyos/issues/150
+ if [ "$_use_llvm_lto" != "none" ]; then
+ echo "Disabling CONFIG_CPU_SRSO..."
+ scripts/config -d CPU_SRSO
+ fi
+
### Selecting CachyOS config
if [ -n "$_cachy_config" ]; then
echo "Enabling CachyOS config..."