summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-10-28 18:16:47 +0200
committerPiotr Gorski2022-10-28 18:16:47 +0200
commit1dce7fb48f710d0542a7d9a12074977bfdf4ffc7 (patch)
tree637813708c73d6cad9a35410095530cf050644c3
parente77117578a8dee9615250b1ac4d3b67b8f1ee8b8 (diff)
downloadaur-1dce7fb48f710d0542a7d9a12074977bfdf4ffc7.tar.gz
Sync with Github
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45f20250ba3a..0e9d39cfccec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -237,6 +237,18 @@ source=(
if [ -n "$_build_zfs" ]; then
source+=("git+https://github.com/cachyos/zfs.git#commit=2eb7f7629a9b1507a8b06ae7efacabea7e394387")
fi
+## Latency NICE Support
+if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
+ source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
+fi
+## NEST Support
+if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
+ source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
+fi
## BMQ Scheduler
if [ "$_cpusched" = "bmq" ]; then
source+=("${_patchsource}/sched/0001-prjc-cachy.patch")
@@ -247,7 +259,7 @@ if [ "$_cpusched" = "pds" ]; then
fi
## BORE Scheduler
if [ "$_cpusched" = "bore" ]; then
- source+=("${_patchsource}/sched/0001-bore.patch")
+ source+=("${_patchsource}/sched/0001-bore-cachy.patch")
fi
## CacULE Scheduler
if [ "$_cpusched" = "cacule" ]; then
@@ -282,19 +294,7 @@ if [ -n "$_bcachefs" ]; then
fi
## rt kernel
if [ -n "$_rtkernel" ]; then
- source+=("${_patchsource}/misc/0001-rt-rc.patch")
-fi
-## NEST Support
-if [ -n "$_nest" ]; then
- if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
- source+=("${_patchsource}/sched/0001-NEST.patch")
- fi
-fi
-## Latency NICE Support
-if [ -n "$_latency_nice" ]; then
- if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
- source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
- fi
+ source+=("${_patchsource}/misc/0001-rt.patch")
fi
export KBUILD_BUILD_HOST=cachyos