summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2022-04-15 01:32:25 +0000
committerPeter Jung2022-04-15 01:32:25 +0000
commit2cf260e48efe553b5324d3700770d997e9af8d62 (patch)
tree80077e69f91a87090adb34abce676e4584e15d7f
parent51885edce42d7cddf66f4dff418f0444371e5dd4 (diff)
downloadaur-2cf260e48efe553b5324d3700770d997e9af8d62.tar.gz
5.17.3-3
-rwxr-xr-x.SRCINFO8
-rw-r--r--PKGBUILD24
-rw-r--r--config4
3 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6321953d7413..0b2f20af04db 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux cacULE scheduler Kernel by CachyOS with other patches and improvements
pkgver = 5.17.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -43,12 +43,13 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-hwmon.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-MG-LRU.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-spf-lru-patches.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-uksm.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-rcu.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-v4l2loopback.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.17/0001-xanmod.patch
source = auto-cpu-optimization.sh
sha256sums = 32d0a8e366b87e1cbde951b9f7a01287546670ba60fac35cccfc8a7c005a162c
- sha256sums = 4c0791ba64d611421f76d7729ae3394d403351149da3eaa733e82d8f1b1f65b6
+ sha256sums = d336c4c1123208ba055055db08f24bfe1c9ae9785f3dbe58b7bb6b60fa6786c9
sha256sums = 33c0d70410ac7e0fccce5796aacea76838b048c79bbdc92eaf2fdbb5eabd4e0d
sha256sums = df466f91e9560e258da5816f037760e511172e789dee01c267ac7213706919b9
sha256sums = b81d81435984662cc5948e5e26389402d6803ceb4cd3fe346f632fdf4c81f9ed
@@ -64,8 +65,9 @@ pkgbase = linux-cacule
sha256sums = ccdc989e3600ec098060696fc87168b655ebbaaaac00d2b424f56c1697c50abb
sha256sums = 27b29c0de9ac4e327f76d060c747196c59536754cb2288c7d121e700d9a976c8
sha256sums = c6e3fe5b1736c343f25632a23318c91ccc8b84e896ce7a0a1f7eb2a05e7a596f
- sha256sums = 0d91172d863ffd56a676619632075b03a18416e55ed3c66f79dfcbac19eefedb
+ sha256sums = 0682d64dd5be9699ccfbd8a2c4f39ab899f6d13e18e5e0f1ca30b282606ac958
sha256sums = 0c71a8f1cf99f01d2f6fdafde8b5b96e1f56b686b505aa2e18396855966c11f9
+ sha256sums = eccb27352c4e87998900a9b8b0e0ec6322c33f542643085a20db45a09c78fdba
sha256sums = 91b8eebde0f0704808b16e0c7a64be791d9c93319ecb05cb4cdb35dcce7387f3
sha256sums = 65d7b7fe507302e77affbfdd2e92991ae37c413c17d6b96559b5794487421d58
sha256sums = aa87843e5e44e0f5ad20e3acacccc54e9931ae5dce6bb9a357731deb19d182b0
diff --git a/PKGBUILD b/PKGBUILD
index 7eb33b7707b8..9dc106c768e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,9 +64,6 @@ _mq_deadline_disable=y
### Disable Kyber I/O scheduler
_kyber_disable=y
-### Enable protect file mappings under memory pressure
-_mm_protect=
-
### Enable multigenerational LRU
_lru_enable=y
@@ -132,7 +129,7 @@ _srcname=linux-${_stable}
#_srcname=linux-${_major}
arch=(x86_64 x86_64_v3)
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
@@ -165,6 +162,7 @@ source=(
"${_patchsource}/0001-hwmon.patch"
"${_patchsource}/0001-MG-LRU.patch"
"${_patchsource}/0001-spf-lru-patches.patch"
+ "${_patchsource}/0001-uksm.patch"
"${_patchsource}/0001-rcu.patch"
"${_patchsource}/0001-v4l2loopback.patch"
"${_patchsource}/0001-xanmod.patch"
@@ -369,19 +367,6 @@ prepare() {
scripts/config --module CONFIG_NETFILTER_XT_TARGET_FULLCONENAT
fi
-
- ### Enable protect mappings under memory pressure
- if [ -n "$_mm_protect" ]; then
- echo "Enabling protect file mappings under memory pressure..."
- scripts/config --enable CONFIG_UNEVICTABLE_FILE
- scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_LOW 0
- scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_MIN 0
- echo "Enabling protect anonymous mappings under memory pressure..."
- scripts/config --enable CONFIG_UNEVICTABLE_ANON
- scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_LOW 0
- scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_MIN 0
- fi
-
### Enable SPF
if [ -n "$_spf_enable" ]; then
echo "Enabling multigenerational LRU..."
@@ -686,7 +671,7 @@ for _p in "${pkgname[@]}"; do
done
sha256sums=('32d0a8e366b87e1cbde951b9f7a01287546670ba60fac35cccfc8a7c005a162c'
- '4c0791ba64d611421f76d7729ae3394d403351149da3eaa733e82d8f1b1f65b6'
+ 'd336c4c1123208ba055055db08f24bfe1c9ae9785f3dbe58b7bb6b60fa6786c9'
'33c0d70410ac7e0fccce5796aacea76838b048c79bbdc92eaf2fdbb5eabd4e0d'
'df466f91e9560e258da5816f037760e511172e789dee01c267ac7213706919b9'
'b81d81435984662cc5948e5e26389402d6803ceb4cd3fe346f632fdf4c81f9ed'
@@ -702,8 +687,9 @@ sha256sums=('32d0a8e366b87e1cbde951b9f7a01287546670ba60fac35cccfc8a7c005a162c'
'ccdc989e3600ec098060696fc87168b655ebbaaaac00d2b424f56c1697c50abb'
'27b29c0de9ac4e327f76d060c747196c59536754cb2288c7d121e700d9a976c8'
'c6e3fe5b1736c343f25632a23318c91ccc8b84e896ce7a0a1f7eb2a05e7a596f'
- '0d91172d863ffd56a676619632075b03a18416e55ed3c66f79dfcbac19eefedb'
+ '0682d64dd5be9699ccfbd8a2c4f39ab899f6d13e18e5e0f1ca30b282606ac958'
'0c71a8f1cf99f01d2f6fdafde8b5b96e1f56b686b505aa2e18396855966c11f9'
+ 'eccb27352c4e87998900a9b8b0e0ec6322c33f542643085a20db45a09c78fdba'
'91b8eebde0f0704808b16e0c7a64be791d9c93319ecb05cb4cdb35dcce7387f3'
'65d7b7fe507302e77affbfdd2e92991ae37c413c17d6b96559b5794487421d58'
'aa87843e5e44e0f5ad20e3acacccc54e9931ae5dce6bb9a357731deb19d182b0'
diff --git a/config b/config
index 3b6451ce4c7a..b55e93086a52 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.17.2 Kernel Configuration
+# Linux/x86 5.17.3 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.2.0"
CONFIG_CC_IS_GCC=y
@@ -1061,6 +1061,8 @@ CONFIG_PHYS_ADDR_T_64BIT=y
CONFIG_VIRT_TO_BUS=y
CONFIG_MMU_NOTIFIER=y
CONFIG_KSM=y
+CONFIG_UKSM=y
+# CONFIG_KSM_LEGACY is not set
CONFIG_DEFAULT_MMAP_MIN_ADDR=65536
CONFIG_ARCH_SUPPORTS_MEMORY_FAILURE=y
CONFIG_MEMORY_FAILURE=y