summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-07-21 10:47:44 +0200
committerPiotr Gorski2022-07-21 10:47:44 +0200
commit32d047baae07a7c7df2b724d597702935ce4a6c4 (patch)
treefe195aca5215eb3e79b5592829d7918e67f443c9
parentb55298e805abf9e49c53e2f2c139437937ab367a (diff)
downloadaur-32d047baae07a7c7df2b724d597702935ce4a6c4.tar.gz
Cleaning, smoothing and adding some comments again
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rwxr-xr-x.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 058c993d62d7..05706e251cc1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = linux-cacule
pkgdesc = Linux cacULE scheduler Kernel by CachyOS with other patches and improvements
pkgver = 5.18.12
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
license = GPL2
makedepends = bc
- makedepends = texlive-latexextra
makedepends = libelf
makedepends = pahole
makedepends = cpio
@@ -15,8 +14,6 @@ pkgbase = linux-cacule
makedepends = tar
makedepends = xz
makedepends = zstd
- makedepends = xmlto
- makedepends = git
makedepends = gcc
makedepends = gcc-libs
makedepends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index 22eb178f9cff..09fdadda5428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -96,6 +96,7 @@ _disable_debug=y
## Enable zram/zswap ZSTD compression
_zstd_compression=y
+# Enable FULLCONENAT
_nf_cone=y
# Clang LTO mode, only available with the "llvm" compiler - options are "no", "full" or "thin".
@@ -109,6 +110,12 @@ _build_zfs=
# Enable bcachefs
_bcachefs=
+# Enable aufsfs
+_aufs=
+
+# Enable spadefs
+_spadfs=
+
if [ -n "$_use_llvm_lto" ]; then
pkgsuffix=${_cpusched}-lto
pkgbase=linux-$pkgsuffix
@@ -128,13 +135,14 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=4
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
options=('!strip')
-makedepends=('bc' 'texlive-latexextra' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'xmlto' 'git' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+makedepends=('bc' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+# LLVM makedepends
if [ -n "$_use_llvm_lto" ]; then
makedepends+=(clang llvm lld python)
BUILD_FLAGS=(
@@ -144,6 +152,11 @@ if [ -n "$_use_llvm_lto" ]; then
LLVM_IAS=1
)
fi
+# ZFS makedepends
+if [ -n "$_build_zfs" ]; then
+ makedepends+=(git)
+
+fi
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/${_major}"
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
@@ -182,6 +195,14 @@ if [ -n "$_bcachefs" ]; then
source+=("${_patchsource}/0001-bcachefs-after-lru.patch")
fi
+if [ -n "$_aufs" ]; then
+source+=("${_patchsource}/0001-aufs-20220620.patch")
+fi
+
+if [ -n "$_spadfs" ]; then
+source+=("${_patchsource}/0001-spadfs-5.18-merge-v1.0.16.patch")
+fi
+
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"