summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Jung2023-01-01 14:54:45 +0100
committerPeter Jung2023-01-01 14:54:45 +0100
commit4b472c530ef5e29df456d7aaea91d480b1d3a7f7 (patch)
treedc7935e2f1ced10ad8046147dbb2415ce29b9b78
parentb593dc93a402b601f4655ad176af850a703b0ae1 (diff)
downloadaur-4b472c530ef5e29df456d7aaea91d480b1d3a7f7.tar.gz
6.1.2-3
Signed-off-by: Peter Jung <admin@ptr1337.dev>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9321a9b16334..3e25544cb264 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux cacULE scheduler Kernel by CachyOS with other patches and improvements
pkgver = 6.1.2
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -29,7 +29,7 @@ pkgbase = linux-cacule
sha256sums = ee41f3c4f599b2f46f08aae428c9243db403e7292eb2c9f04ee34909b038d1ae
sha256sums = d4f3fc2581e338835a33983cca18bfb3225450a07c456c48c9b051c03236955a
sha256sums = 32e77b3b71225c9f04df2d44c25f982773a8fff9927d26788366baab5e242e74
- sha256sums = 1ec422b623d99bcac518075d498e2a32f91151a532edb4ba51b993667b6c32a5
+ sha256sums = 53b2918c27a786adde50a28862c63f7c22df1697dfdcf3792123402e98d5a857
sha256sums = 48afb08df95035b315bb882c03d7b66d320bccf54977822050a5c3cd7acd2709
pkgname = linux-cacule
diff --git a/PKGBUILD b/PKGBUILD
index 2597b12970a4..9f16e99d2a87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -102,7 +102,7 @@ _lru_config=${_lru_config-'standard'}
# 'standard' - enable per-VMA locking
# 'stats' - enable per-VMA locking with stats
# 'none' - disable per-VMA locking
-_vma_config=${_vma_config-'standard'}
+_vma_config=${_vma_config-'none'}
### Transparent Hugepages
# ATTENTION - one of two predefined values should be selected!
@@ -210,7 +210,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux cacULE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=1
+pkgrel=3
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -299,6 +299,10 @@ if [ -n "$_use_gcc_lto" ]; then
source+=("${_patchsource}/misc/gcc-lto/0001-gcc-LTO-support-for-the-kernel.patch"
"${_patchsource}/misc/gcc-lto/0002-gcc-lto-no-pie.patch")
fi
+## Use vma lock as an extra patch since it has some issues right now
+if [[ "$_vma_config" = "standard" || "$_vma_config" = "stats" ]]; then
+ source+=("${_patchsource}/misc/0001-Introduce-per-VMA-lock.patch")
+fi
export KBUILD_BUILD_HOST=cachyos
export KBUILD_BUILD_USER=$pkgbase
@@ -1047,5 +1051,5 @@ done
sha256sums=('ee41f3c4f599b2f46f08aae428c9243db403e7292eb2c9f04ee34909b038d1ae'
'd4f3fc2581e338835a33983cca18bfb3225450a07c456c48c9b051c03236955a'
'32e77b3b71225c9f04df2d44c25f982773a8fff9927d26788366baab5e242e74'
- '1ec422b623d99bcac518075d498e2a32f91151a532edb4ba51b993667b6c32a5'
+ '53b2918c27a786adde50a28862c63f7c22df1697dfdcf3792123402e98d5a857'
'48afb08df95035b315bb882c03d7b66d320bccf54977822050a5c3cd7acd2709')