summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.Jung2021-09-26 13:27:07 +0000
committerP.Jung2021-09-26 13:27:07 +0000
commit86b180630b16f239adf9524711d314fd59c728f8 (patch)
tree90289422bea19e8215c14c05b11f060f24cf1db0
parentee05511ec974caedb77e9f92607438c690b4a001 (diff)
downloadaur-86b180630b16f239adf9524711d314fd59c728f8.tar.gz
5.14.8 + AMD-CPPC-v2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5fcbc129e81..62b8e8b46aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux-CacULE Kernel by Hamad Marri and with some other patchsets
- pkgver = 5.14.7
- pkgrel = 3
+ pkgver = 5.14.8
+ pkgrel = 1
url = https://github.com/ptr1337/linux-cacule
arch = x86_64
arch = x86_64_v3
@@ -19,12 +19,13 @@ pkgbase = linux-cacule
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.7.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.8.tar.xz
source = config
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/arch-patches-v8/0001-arch-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE/v5.14/cacule-5.14.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0007-string.patch
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/allpollingrate.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/0001-Allow-polling-rate-to-be-set-for-all-usb-devices.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0001-AMD-CPPC.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/zen-tweaks-cacule.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/ll-patches/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/ll-patches/0003-sched-core-nr_migrate-256-increases-number-of-tasks-.patch
@@ -51,12 +52,13 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/0001-v4l2loopback.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/0001-ksm.patch
source = auto-cpu-optimization.sh
- md5sums = 4119cf1e59ef6f109b9be9451a0899ae
+ md5sums = ce6434b646ade20e292fb28c1aacde58
md5sums = 466239b4e940330f7d225a177916c0cb
md5sums = ef749be7f2048456ae738f93229bf354
md5sums = 40a9380b2884f5d417791f06389ba57e
md5sums = d6e5581b4fade267a28deb8e73d236f5
- md5sums = f154315498da9bf593c11d88041bde48
+ md5sums = 2e2baa635eda7d6a66b5f7437c055a37
+ md5sums = 302cbad3c979395f37307a094f6d8fd5
md5sums = 9d7612159f8745044254077ce8a76df6
md5sums = f8e172e9ea554bbb1053eb122c3ace35
md5sums = af7328eb8c72c754e5bc8c7be1ca2f1c
@@ -97,5 +99,5 @@ pkgname = linux-cacule
pkgname = linux-cacule-headers
pkgdesc = Headers and scripts for building modules for the Linux-CacULE Kernel by Hamad Marri and with some other patchsets
- depends = linux-cacule=5.14.7
+ depends = linux-cacule=5.14.8
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 85d74542cff3..e83046980297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -74,8 +74,8 @@ _use_current=
pkgbase=linux-cacule
pkgname=('linux-cacule' 'linux-cacule-headers')
pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.14.7
-pkgrel=3
+pkgver=5.14.8
+pkgrel=1
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-CacULE Kernel by Hamad Marri and with some other patchsets'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -94,8 +94,8 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_caculepatches}/v5.14/cacule-5.14.patch"
# "${_patchsource}/misc/0004-folio-mm.patch"
"${_patchsource}/misc/0007-string.patch"
- "${_patchsource}/misc/allpollingrate.patch"
-# "${_patchsource}/misc/0001-AMD-CPPC.patch"
+ "${_patchsource}/0001-Allow-polling-rate-to-be-set-for-all-usb-devices.patch"
+ "${_patchsource}/misc/0001-AMD-CPPC.patch"
"${_patchsource}/misc/zen-tweaks-cacule.patch"
"${_patchsource}/ll-patches/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
"${_patchsource}/ll-patches/0003-sched-core-nr_migrate-256-increases-number-of-tasks-.patch"
@@ -355,7 +355,7 @@ prepare() {
scripts/config --enable CONFIG_NTFS3_LZX_XPRESS
scripts/config --enable CONFIG_NTFS3_FS_POSIX_ACL
scripts/config --enable CONFIG_ZEN_INTERACTIVE
-# scripts/config --enable CONFIG_x86_AMD_PSTATE
+ scripts/config --enable CONFIG_x86_AMD_PSTATE
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
if [ -n "$_use_current" ]; then
@@ -522,12 +522,13 @@ package_linux-cacule-headers() {
}
-md5sums=('4119cf1e59ef6f109b9be9451a0899ae'
+md5sums=('ce6434b646ade20e292fb28c1aacde58'
'466239b4e940330f7d225a177916c0cb'
'ef749be7f2048456ae738f93229bf354'
'40a9380b2884f5d417791f06389ba57e'
'd6e5581b4fade267a28deb8e73d236f5'
- 'f154315498da9bf593c11d88041bde48'
+ '2e2baa635eda7d6a66b5f7437c055a37'
+ '302cbad3c979395f37307a094f6d8fd5'
'9d7612159f8745044254077ce8a76df6'
'f8e172e9ea554bbb1053eb122c3ace35'
'af7328eb8c72c754e5bc8c7be1ca2f1c'