summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. Jung2022-01-06 03:08:02 +0000
committerP. Jung2022-01-06 03:08:02 +0000
commit92962bae0a8aa49ab78408eabf6876f912c1c7b1 (patch)
tree451564812bb41ddcb0b712018b31b3a8d2c007b3
parent9ea5fd3e557ec94318fd98dada17f6849b4b3d7b (diff)
downloadaur-92962bae0a8aa49ab78408eabf6876f912c1c7b1.tar.gz
5.15.13
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf23cbf8117d..f893f90556d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-cacule
pkgdesc = Linux CacULE scheduler Kernel by CachyOS and with some other patches and other improvements
- pkgver = 5.15.12
+ pkgver = 5.15.13
pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
@@ -19,9 +19,9 @@ pkgbase = linux-cacule
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.12.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.13.tar.xz
source = config
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE/v5.15/cacule-5.15-full.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/cacule/cacule-5.15-full.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-arch-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-cfi.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-lru-patches.patch
@@ -52,13 +52,13 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-sbitmap-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-zstd.patch
source = auto-cpu-optimization.sh
- md5sums = 7c3faf14ec344d6d0219b6a8b2475726
+ md5sums = 4423a9fc25fcaa9e562c0f28e03960b3
md5sums = 788dcd568f1c00441ad9746706e4f1bc
md5sums = afdbe964cd00357ef7248553ab9db091
md5sums = ef9fa3407854cea8e78112c25bb72e41
md5sums = e3fa8507aed6ef3ce37e62f18fe9b7e1
md5sums = 1f3becd94390729d940a60b1e9b872b1
- md5sums = ef446a32fe115b59710a122009bb1d49
+ md5sums = 9ce207e47ad186b612050bd83641a697
md5sums = dccfe71705b24d3fb1f51aaf2016216d
md5sums = 53f037488a66667220c263f92ded333d
md5sums = 2a8097ba46be56fbbe3967e9c34c9a0b
@@ -72,10 +72,10 @@ pkgbase = linux-cacule
md5sums = 8bda7327ae759b1b52e3b617952bd964
md5sums = 8c354c3d1962ec6785db7f0c3fbbab03
md5sums = b6b2c2c6b4761aa5a8dea6ac0add8736
- md5sums = 265ac5714001f018c5bc7f99637c5181
+ md5sums = c8546d67979e5f33f819284c11daa9c5
md5sums = 08c84362cb916b30d9c77e35b1b3bc54
md5sums = 7d28f804d6b74f9a22ad30d67af5a669
- md5sums = 56fdf3562b041c0408d9751b7e447977
+ md5sums = 2130bb325438a2fc880593c5e345521f
md5sums = b09b84168822521426f197610727618b
md5sums = d9a892f66631615a72bdc93ee7397afa
md5sums = bc64b1d1a9c95b07c28457f7214ebf81
@@ -99,5 +99,5 @@ pkgname = linux-cacule
pkgname = linux-cacule-headers
pkgdesc = Headers and scripts for building modules for the Linux CacULE scheduler Kernel by CachyOS and with some other patches and other improvements
- depends = linux-cacule=5.15.12
+ depends = linux-cacule=5.15.13
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index b49bf29f54e5..904fcf67360a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -122,7 +122,7 @@ else
pkgbase=linux-cacule
fi
_major=5.15
-_minor=12
+_minor=13
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
arch=(x86_64 x86_64_v3)
@@ -141,12 +141,11 @@ fi
if [ -n "$_use_llvm_lto" ]; then
makedepends+=(clang llvm lld python)
fi
-_caculepatches="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE"
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15"
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
"config"
- "${_caculepatches}/v5.15/cacule-5.15-full.patch"
+ "${_patchsource}/cacule/cacule-5.15-full.patch"
"${_patchsource}/0001-arch-patches.patch"
"${_patchsource}/0001-cfi.patch"
"${_patchsource}/0001-lru-patches.patch"
@@ -671,13 +670,13 @@ for _p in "${pkgname[@]}"; do
done
-md5sums=('7c3faf14ec344d6d0219b6a8b2475726'
+md5sums=('4423a9fc25fcaa9e562c0f28e03960b3'
'788dcd568f1c00441ad9746706e4f1bc'
'afdbe964cd00357ef7248553ab9db091'
'ef9fa3407854cea8e78112c25bb72e41'
'e3fa8507aed6ef3ce37e62f18fe9b7e1'
'1f3becd94390729d940a60b1e9b872b1'
- 'ef446a32fe115b59710a122009bb1d49'
+ '9ce207e47ad186b612050bd83641a697'
'dccfe71705b24d3fb1f51aaf2016216d'
'53f037488a66667220c263f92ded333d'
'2a8097ba46be56fbbe3967e9c34c9a0b'
@@ -691,10 +690,10 @@ md5sums=('7c3faf14ec344d6d0219b6a8b2475726'
'8bda7327ae759b1b52e3b617952bd964'
'8c354c3d1962ec6785db7f0c3fbbab03'
'b6b2c2c6b4761aa5a8dea6ac0add8736'
- '265ac5714001f018c5bc7f99637c5181'
+ 'c8546d67979e5f33f819284c11daa9c5'
'08c84362cb916b30d9c77e35b1b3bc54'
'7d28f804d6b74f9a22ad30d67af5a669'
- '56fdf3562b041c0408d9751b7e447977'
+ '2130bb325438a2fc880593c5e345521f'
'b09b84168822521426f197610727618b'
'd9a892f66631615a72bdc93ee7397afa'
'bc64b1d1a9c95b07c28457f7214ebf81'