summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptr13372021-05-23 02:55:03 +0200
committerptr13372021-05-23 02:55:03 +0200
commita7b4d7aef58a5c24aa62487dd65f1fda04cd98cf (patch)
treee7eff78248d3cc5ea74ae9485498e797ffb09b98
parent0bd0b08c6a14e5503cd5f5a3d924715fcec652b6 (diff)
downloadaur-a7b4d7aef58a5c24aa62487dd65f1fda04cd98cf.tar.gz
reverted localmod
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f35fc06eaf18..d177d44c6b23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux-CacULE Kernel by Hamad Marri and with some other patchsets
pkgver = 5.12.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hamadmarri/cacule-cpu-scheduler
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 300f9040d214..a210a1bff8c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,6 +27,16 @@ _kyber_disable=y
_2k_HZ_ticks=
_1k_HZ_ticks=y
_500_HZ_ticks=
+# Compile ONLY used modules to VASTLYreduce the number of modules built
+# and the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD read the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+_localmodcfg=
+
### Do not edit below this line unless you know what you're doing
@@ -40,7 +50,7 @@ pkgver=${_major}
#_stable=${_major}.${_minor}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_major}
-pkgrel=1
+pkgrel=2
pkgdesc='Linux-CacULE Kernel by Hamad Marri and with some other patchsets'
arch=('x86_64')
url="https://github.com/hamadmarri/cacule-cpu-scheduler"
@@ -279,6 +289,18 @@ prepare() {
scripts/config --module CONFIG_VHBA
scripts/config --disable CONFIG_BPF_PRELOAD
+ ### Optionally load needed modules for the make localmodconfig
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -f $HOME/.config/modprobed.db ]; then
+ echo "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ echo "No modprobed.db data found"
+ exit
+ fi
+ fi
+
### Save configuration for later reuse
echo "Save config for reuse"
cat .config > "${startdir}/config.last"