summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-28 01:23:29 +0200
committerPiotr Gorski2022-09-28 01:23:29 +0200
commitaf32f6cde2e2cd38f22e598ce94e90d2cce83f6e (patch)
tree81049d4c74083c058b6ecac218267cb7aac3d7c4
parenta857309f1458d85226748e08b2df2972386536a3 (diff)
downloadaur-af32f6cde2e2cd38f22e598ce94e90d2cce83f6e.tar.gz
Improve nest and latency nice flags
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99ba220744c2..881ee9f4c20f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -272,11 +272,15 @@ if [ -n "$_bcachefs" ]; then
fi
## NEST Support
if [ -n "$_nest" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/sched/0001-NEST.patch")
+ fi
fi
## Latency NICE Support
if [ -n "$_latency_nice" ]; then
+ if [[ "$_cpusched" = "bore" || "$_cpusched" = "cfs" || "$_cpusched" = "hardened" ]]; then
source+=("${_patchsource}/misc/0001-Add-latency-priority-for-CFS-class.patch")
+ fi
fi
export KBUILD_BUILD_HOST=cachyos