summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptr13372021-05-08 10:43:39 +0200
committerptr13372021-05-08 10:43:39 +0200
commitbcb28aa9538bd3118f76cb18275ce3a9f67f7a93 (patch)
treedfe583a49964ad78de59cc39bed903a4dd26bb85
parent03ae92e77f86b7c047299d9e8e959378c7e7b431 (diff)
downloadaur-bcb28aa9538bd3118f76cb18275ce3a9f67f7a93.tar.gz
fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62d45cd9e455..4eed3b036986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux-CacULE Kernel by Hamad Marri and with some other patchsets
pkgver = 5.12.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hamadmarri/cacule-cpu-scheduler
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index fd883b4731d6..42a782ba06de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,8 +24,8 @@ _deadline_disable=y
### Disable Kyber I/O scheduler
_kyber_disable=y
### Running with a 2000 HZ, 1000HZ or 500HZ tick rate
-_2k_HZ_ticks=y
-_1k_HZ_ticks=
+_2k_HZ_ticks=
+_1k_HZ_ticks=y
_500_HZ_ticks=
### Tweak kernel options prior to a build via nconfig
_makenconfig=
@@ -64,7 +64,7 @@ pkgver=${_major}
#_stable=${_major}.${_minor}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_major}
-pkgrel=2
+pkgrel=3
pkgdesc='Linux-CacULE Kernel by Hamad Marri and with some other patchsets'
arch=('x86_64')
url="https://github.com/hamadmarri/cacule-cpu-scheduler"
@@ -261,8 +261,8 @@ prepare() {
echo "Enabling multigenerational LRU..."
scripts/config --enable CONFIG_HAVE_ARCH_PARENT_PMD_YOUNG
scripts/config --enable CONFIG_LRU_GEN
- scripts/config --set-val CONFIG_NR_LRU_GENS 7
- scripts/config --set-val CONFIG_TIERS_PER_GEN 4
+ scripts/config --set-val CONFIG_NR_LRU_GENS 5
+ scripts/config --set-val CONFIG_TIERS_PER_GEN 3
scripts/config --enable CONFIG_LRU_GEN_ENABLED
scripts/config --disable CONFIG_LRU_GEN_STATS
@@ -279,7 +279,6 @@ prepare() {
scripts/config --enable CONFIG_CACULE_SCHED
scripts/config --enable CONFIG_FAIR_GROUP_SCHED
scripts/config --enable CONFIG_SCHED_AUTOGROUP
- #scripts/config --set-val CONFIG_NR_CPUS "12"
scripts/config --disable CONFIG_SCHED_DEBUG
scripts/config --disable CONFIG_SCHED_INFO
scripts/config --disable CONFIG_SCHEDSTATS
@@ -288,6 +287,8 @@ prepare() {
##TEST##
scripts/config --enable CONFIG_NO_HZ_FULL
scripts/config --enable CONFIG_NO_HZ
+ scripts/config --disable CONFIG_NO_HZ_IDLE
+ scripts/config --disable CONFIG_HZ_PERIODIC
scripts/config --enable CONFIG_CONTEXT_TRACKING
scripts/config --disable CONFIG_CONTEXT_TRACKING_FORCE
echo "Enabling KBUILD_CFLAGS -O3..."