summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. Jung2021-12-14 16:53:11 +0000
committerP. Jung2021-12-14 16:53:11 +0000
commitf31640b50e771b92d6c504d690b18a4cd6b74b14 (patch)
treee19a7c856403b13b3aa30dae869b0cc94422a30e
parentfb16ab6d4b1316b8754ed6029a8edbed8d218fe6 (diff)
downloadaur-f31640b50e771b92d6c504d690b18a4cd6b74b14.tar.gz
5.15.8-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD371
2 files changed, 192 insertions, 193 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28a098a5f85a..0cb205dda869 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux CacULE scheduler Kernel by CachyOS and with some other patches and other improvements
- pkgver = 5.15.7
- pkgrel = 2
+ pkgver = 5.15.8
+ pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -19,7 +19,7 @@ pkgbase = linux-cacule
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.7.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.8.tar.xz
source = config
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE/v5.15/cacule-5.15-full.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-arch-patches.patch
@@ -41,7 +41,7 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-futex-wait.v-fsync-winesync.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-hwmon-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-ksmbd-patches.patch
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-damon.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-page-table-check.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-pf-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-lqx-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-lrng-patches.patch
@@ -52,7 +52,7 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-zstd.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.15/0001-xfs-backport.patch
source = auto-cpu-optimization.sh
- md5sums = b79700122766ccf561f032eb3c8da27e
+ md5sums = 5b04a1db6305c993d7f55db334a2b415
md5sums = d97e86d9464dd34683f67de4d4a595c0
md5sums = afdbe964cd00357ef7248553ab9db091
md5sums = 2627c6fcd9760b0e7a3553500db0a7e1
@@ -74,7 +74,7 @@ pkgbase = linux-cacule
md5sums = 8c354c3d1962ec6785db7f0c3fbbab03
md5sums = 9b6369bc4c58ad0d9195b5c204ed4b8a
md5sums = c6efda5716e4ff79ebdbc963bebd851a
- md5sums = 408dfabb34f2b79aa2f5044b052703db
+ md5sums = 152706f6ebbe9917c6a5955cd5447344
md5sums = 08c84362cb916b30d9c77e35b1b3bc54
md5sums = 56fdf3562b041c0408d9751b7e447977
md5sums = b09b84168822521426f197610727618b
@@ -99,5 +99,5 @@ pkgname = linux-cacule
pkgname = linux-cacule-headers
pkgdesc = Headers and scripts for building modules for the Linux CacULE scheduler Kernel by CachyOS and with some other patches and other improvements
- depends = linux-cacule=5.15.7
+ depends = linux-cacule=5.15.8
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 8c6af4bc51c9..c45f919a75a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,7 @@ _fsync=y
#enable winesync
_winesync=y
-### Running with a 2000 HZ, 1000HZ, 750Hz or 500HZ tick rate
+### Running with a 1000HZ, 750Hz or 500HZ tick rate
_2k_HZ_ticks=
_1k_HZ_ticks=
_750_HZ_ticks=y
@@ -76,6 +76,8 @@ _lrng_enable=y
### Enable DAMON
_damon=
+_use_page_check=y
+
## Apply Kernel automatic Optimization
_use_auto_optimization=y
@@ -129,13 +131,13 @@ elif [ "$_cpusched" = "rdb" ]; then
pkgbase=linux-cacule-rdb
fi
_major=5.15
-_minor=7
+_minor=8
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
arch=(x86_64 x86_64_v3)
pkgdesc='Linux CacULE scheduler Kernel by CachyOS and with some other patches and other improvements'
_srcname=linux-${pkgver}
-pkgrel=2
+pkgrel=1
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
@@ -173,7 +175,8 @@ source=(
"${_patchsource}/0001-futex-wait.v-fsync-winesync.patch"
"${_patchsource}/0001-hwmon-patches.patch"
"${_patchsource}/0001-ksmbd-patches.patch"
- "${_patchsource}/0001-damon.patch"
+ "${_patchsource}/0001-page-table-check.patch"
+# "${_patchsource}/0001-damon-patches.patch"
"${_patchsource}/0001-pf-patches.patch"
"${_patchsource}/0001-lqx-patches.patch"
"${_patchsource}/0001-lrng-patches.patch"
@@ -242,186 +245,182 @@ prepare() {
fi
fi
- if [ -n "$_use_cfi" ] && [ -n "$_use_llvm_lto" ]; then
- scripts/config --enable CONFIG_ARCH_SUPPORTS_CFI_CLANG
- scripts/config --enable CONFIG_CFI_CLANG
- fi
-
- if [ -n "$_use_pgo" ]; then
- scripts/config --enable CONFIG_ARCH_SUPPORTS_PGO_CLANG
- scripts/config --enable DEBUG_FS
- scripts/config --enable CONFIG_PGO_CLANG
- fi
-
- ### Microarchitecture Optimization (GCC/CLANG)
- if [ -n "$_use_auto_optimization" ]; then
- "${srcdir}"/auto-cpu-optimization.sh
- fi
-
-
- if [ -n "$_use_optimization_select" ]; then
- source "${startdir}"/configure
- cpu_arch
- fi
-
-
- ### Optionally set tickrate to 2000HZ
- if [ -n "$_2k_HZ_ticks" ]; then
- echo "Setting tick rate to 2k..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_2000
- scripts/config --set-val CONFIG_HZ 2000
- fi
-
- ### Optionally set tickrate to 1000
- if [ -n "$_1k_HZ_ticks" ]; then
- echo "Setting tick rate to 1k..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_1000
- scripts/config --set-val CONFIG_HZ 1000
- fi
-
- ### Optionally set tickrate to 750HZ
- if [ -n "$_750_HZ_ticks" ]; then
- echo "Setting tick rate to 750HZ..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_750
- scripts/config --set-val CONFIG_HZ 750
- fi
-
- ### Optionally set tickrate to 600HZ
- if [ -n "$_600_HZ_ticks" ]; then
- echo "Setting tick rate to 600HZ..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_600
- scripts/config --set-val CONFIG_HZ 600
- fi
-
- ### Optionally set tickrate to 500HZ
- if [ -n "$_500_HZ_ticks" ]; then
- echo "Setting tick rate to 500HZ..."
- scripts/config --disable CONFIG_HZ_300
- scripts/config --enable CONFIG_HZ_500
- scripts/config --set-val CONFIG_HZ 500
- fi
-
- ### Optionally disable NUMA for 64-bit kernels only
- # (x86 kernels do not support NUMA)
- if [ -n "$_NUMAdisable" ]; then
- echo "Disabling NUMA from kernel config..."
- scripts/config --disable CONFIG_NUMA
- fi
-
- if [ -n "$_fsync" ]; then
- echo "Enable Fsync support"
- scripts/config --enable CONFIG_FUTEX
- scripts/config --enable CONFIG_FUTEX_PI
- fi
-
-
- if [ -n "$_winesync" ]; then
- echo "Enable winesync support"
- scripts/config --module CONFIG_WINESYNC
- fi
-
- ### Disable MQ-Deadline I/O scheduler
- if [ -n "$_mq_deadline_disable" ]; then
- echo "Disabling MQ-Deadline I/O scheduler..."
- scripts/config --disable CONFIG_MQ_IOSCHED_DEADLINE
- fi
-
- ### Disable Kyber I/O scheduler
- if [ -n "$_kyber_disable" ]; then
- echo "Disabling Kyber I/O scheduler..."
- scripts/config --disable CONFIG_MQ_IOSCHED_KYBER
- fi
-
-
- ### Enable protect mappings under memory pressure
- if [ -n "$_mm_protect" ]; then
- echo "Enabling protect file mappings under memory pressure..."
- scripts/config --enable CONFIG_UNEVICTABLE_FILE
- scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_LOW 0
- scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_MIN 0
- echo "Enabling protect anonymous mappings under memory pressure..."
- scripts/config --enable CONFIG_UNEVICTABLE_ANON
- scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_LOW 0
- scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_MIN 0
- fi
-
- ### Enable multigenerational LRU
- if [ -n "$_lru_enable" ]; then
- echo "Enabling multigenerational LRU..."
- scripts/config --enable CONFIG_ARCH_HAS_NONLEAF_PMD_YOUNG
- scripts/config --enable CONFIG_LRU_GEN
- scripts/config --set-val CONFIG_NR_LRU_GENS 7
- scripts/config --set-val CONFIG_TIERS_PER_GEN 4
- scripts/config --enable CONFIG_LRU_GEN_ENABLED
- scripts/config --disable CONFIG_LRU_GEN_STATS
- fi
-
- ### Enable DAMON
- if [ -n "$_damon" ]; then
- echo "Enabling DAMON..."
- scripts/config --enable CONFIG_DAMON
- scripts/config --disable CONFIG_DAMON_VADDR
- scripts/config --disable CONFIG_DAMON_DBGFS
- scripts/config --enable CONFIG_DAMON_PADDR
- scripts/config --enable CONFIG_DAMON_RECLAIM
- fi
-
- ### Enable Linux Random Number Generator
- if [ -n "$_lrng_enable" ]; then
- echo "Enabling Linux Random Number Generator ..."
- echo "Enabling Linux Random Number Generator with pfkernel config..."
- scripts/config --enable CONFIG_LRNG
- scripts/config --enable CONFIG_LRNG_OVERSAMPLE_ENTROPY_SOURCES
- scripts/config --set-val CONFIG_CONFIG_LRNG_OVERSAMPLE_ES_BITS 64
- scripts/config --set-val CONFIG_LRNG_SEED_BUFFER_INIT_ADD_BITS 128
- scripts/config --enable CONFIG_LRNG_IRQ
- scripts/config --enable CONFIG_LRNG_CONTINUOUS_COMPRESSION_ENABLED
- scripts/config --disable CONFIG_LRNG_CONTINUOUS_COMPRESSION_DISABLED
- scripts/config --enable CONFIG_LRNG_ENABLE_CONTINUOUS_COMPRESSION
- scripts/config --enable CONFIG_LRNG_SWITCHABLE_CONTINUOUS_COMPRESSION
- scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_512
- scripts/config --enable CONFIG_LRNG_COLLECTION_SIZE_1024
- scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_2048
- scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_4096
- scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_8192
- scripts/config --set-val CONFIG_LRNG_COLLECTION_SIZE 1024
- scripts/config --enable CONFIG_LRNG_HEALTH_TESTS
- scripts/config --set-val CONFIG_LRNG_RCT_CUTOFF 31
- scripts/config --set-val CONFIG_LRNG_APT_CUTOFF 325
- scripts/config --set-val CONFIG_LRNG_IRQ_ENTROPY_RATE 256
- scripts/config --enable CONFIG_LRNG_JENT
- scripts/config --set-val CONFIG_LRNG_JENT_ENTROPY_RATE 16
- scripts/config --enable CONFIG_LRNG_CPU
- scripts/config --set-val CONFIG_LRNG_CPU_ENTROPY_RATE 8
- scripts/config --enable CONFIG_LRNG_DRNG_SWITCH
- scripts/config --enable CONFIG_LRNG_KCAPI_HASH
- scripts/config --module CONFIG_LRNG_DRBG
- scripts/config --module CONFIG_LRNG_KCAPI
- scripts/config --enable CONFIG_LRNG_TESTING_MENU
- scripts/config --disable CONFIG_LRNG_RAW_HIRES_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_JIFFIES_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_IRQ_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_IRQFLAGS_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_RETIP_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_REGS_ENTROPY
- scripts/config --disable CONFIG_LRNG_RAW_ARRAY
- scripts/config --disable CONFIG_LRNG_IRQ_PERF
- scripts/config --disable CONFIG_LRNG_ACVT_HASH
- scripts/config --enable CONFIG_LRNG_RUNTIME_ES_CONFIG
- scripts/config --disable CONFIG_LRNG_RUNTIME_MAX_WO_RESEED_CONFIG
- scripts/config --disable CONFIG_LRNG_TEST_CPU_ES_COMPRESSION
- scripts/config --enable CONFIG_LRNG_SELFTEST
- scripts/config --disable CONFIG_LRNG_SELFTEST_PANIC
- fi
-
- echo "Enable LLVM LTO"
- if [ -n "$_use_llvm_lto" ]; then
- scripts/config --disable CONFIG_LTO_NONE
- fi
+ if [ -n "$_use_cfi" ] && [ -n "$_use_llvm_lto" ]; then
+ scripts/config --enable CONFIG_ARCH_SUPPORTS_CFI_CLANG
+ scripts/config --enable CONFIG_CFI_CLANG
+ fi
+
+ if [ -n "$_use_pgo" ]; then
+ scripts/config --enable CONFIG_ARCH_SUPPORTS_PGO_CLANG
+ scripts/config --enable DEBUG_FS
+ scripts/config --enable CONFIG_PGO_CLANG
+ fi
+
+ ### Microarchitecture Optimization (GCC/CLANG)
+ if [ -n "$_use_auto_optimization" ]; then
+ "${srcdir}"/auto-cpu-optimization.sh
+ fi
+
+
+ if [ -n "$_use_optimization_select" ]; then
+ source "${startdir}"/configure
+ cpu_arch
+ fi
+
+ ### Optionally set tickrate to 1000
+ if [ -n "$_1k_HZ_ticks" ]; then
+ echo "Setting tick rate to 1k..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_1000
+ scripts/config --set-val CONFIG_HZ 1000
+ fi
+
+ ### Optionally set tickrate to 750HZ
+ if [ -n "$_750_HZ_ticks" ]; then
+ echo "Setting tick rate to 750HZ..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_750
+ scripts/config --set-val CONFIG_HZ 750
+ fi
+
+ ### Optionally set tickrate to 600HZ
+ if [ -n "$_600_HZ_ticks" ]; then
+ echo "Setting tick rate to 600HZ..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_600
+ scripts/config --set-val CONFIG_HZ 600
+ fi
+
+ ### Optionally set tickrate to 500HZ
+ if [ -n "$_500_HZ_ticks" ]; then
+ echo "Setting tick rate to 500HZ..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_500
+ scripts/config --set-val CONFIG_HZ 500
+ fi
+
+ ### Optionally disable NUMA for 64-bit kernels only
+ # (x86 kernels do not support NUMA)
+ if [ -n "$_NUMAdisable" ]; then
+ echo "Disabling NUMA from kernel config..."
+ scripts/config --disable CONFIG_NUMA
+ fi
+
+ if [ -n "$_fsync" ]; then
+ echo "Enable Fsync support"
+ scripts/config --enable CONFIG_FUTEX
+ scripts/config --enable CONFIG_FUTEX_PI
+ fi
+
+
+ if [ -n "$_winesync" ]; then
+ echo "Enable winesync support"
+ scripts/config --module CONFIG_WINESYNC
+ fi
+
+ ### Disable MQ-Deadline I/O scheduler
+ if [ -n "$_mq_deadline_disable" ]; then
+ echo "Disabling MQ-Deadline I/O scheduler..."
+ scripts/config --disable CONFIG_MQ_IOSCHED_DEADLINE
+ fi
+
+ ### Disable Kyber I/O scheduler
+ if [ -n "$_kyber_disable" ]; then
+ echo "Disabling Kyber I/O scheduler..."
+ scripts/config --disable CONFIG_MQ_IOSCHED_KYBER
+ fi
+
+
+ ### Enable protect mappings under memory pressure
+ if [ -n "$_mm_protect" ]; then
+ echo "Enabling protect file mappings under memory pressure..."
+ scripts/config --enable CONFIG_UNEVICTABLE_FILE
+ scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_LOW 0
+ scripts/config --set-val CONFIG_UNEVICTABLE_FILE_KBYTES_MIN 0
+ echo "Enabling protect anonymous mappings under memory pressure..."
+ scripts/config --enable CONFIG_UNEVICTABLE_ANON
+ scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_LOW 0
+ scripts/config --set-val CONFIG_UNEVICTABLE_ANON_KBYTES_MIN 0
+ fi
+
+ ### Enable multigenerational LRU
+ if [ -n "$_lru_enable" ]; then
+ echo "Enabling multigenerational LRU..."
+ scripts/config --enable CONFIG_ARCH_HAS_NONLEAF_PMD_YOUNG
+ scripts/config --enable CONFIG_LRU_GEN
+ scripts/config --set-val CONFIG_NR_LRU_GENS 7
+ scripts/config --set-val CONFIG_TIERS_PER_GEN 4
+ scripts/config --enable CONFIG_LRU_GEN_ENABLED
+ scripts/config --disable CONFIG_LRU_GEN_STATS
+ fi
+
+ ### Enable DAMON
+ if [ -n "$_damon" ]; then
+ echo "Enabling DAMON..."
+ scripts/config --enable CONFIG_DAMON
+ scripts/config --disable CONFIG_DAMON_VADDR
+ scripts/config --disable CONFIG_DAMON_DBGFS
+ scripts/config --enable CONFIG_DAMON_PADDR
+ scripts/config --enable CONFIG_DAMON_RECLAIM
+ fi
+ if [ -n "$_use_page_check" ]; then
+ echo "Enable Page Table Check"
+ scripts/config --enable ARCH_SUPPORTS_PAGE_TABLE_CHECK
+ scripts/config --enable CONFIG_PAGE_TABLE_CHECK
+ scripts/config --enable CONFIG_PAGE_TABLE_CHECK_ENFORCED
+ fi
+ ### Enable Linux Random Number Generator
+ if [ -n "$_lrng_enable" ]; then
+ echo "Enabling Linux Random Number Generator ..."
+ echo "Enabling Linux Random Number Generator with pfkernel config..."
+ scripts/config --enable CONFIG_LRNG
+ scripts/config --enable CONFIG_LRNG_OVERSAMPLE_ENTROPY_SOURCES
+ scripts/config --set-val CONFIG_CONFIG_LRNG_OVERSAMPLE_ES_BITS 64
+ scripts/config --set-val CONFIG_LRNG_SEED_BUFFER_INIT_ADD_BITS 128
+ scripts/config --enable CONFIG_LRNG_IRQ
+ scripts/config --enable CONFIG_LRNG_CONTINUOUS_COMPRESSION_ENABLED
+ scripts/config --disable CONFIG_LRNG_CONTINUOUS_COMPRESSION_DISABLED
+ scripts/config --enable CONFIG_LRNG_ENABLE_CONTINUOUS_COMPRESSION
+ scripts/config --enable CONFIG_LRNG_SWITCHABLE_CONTINUOUS_COMPRESSION
+ scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_512
+ scripts/config --enable CONFIG_LRNG_COLLECTION_SIZE_1024
+ scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_2048
+ scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_4096
+ scripts/config --disable CONFIG_LRNG_COLLECTION_SIZE_8192
+ scripts/config --set-val CONFIG_LRNG_COLLECTION_SIZE 1024
+ scripts/config --enable CONFIG_LRNG_HEALTH_TESTS
+ scripts/config --set-val CONFIG_LRNG_RCT_CUTOFF 31
+ scripts/config --set-val CONFIG_LRNG_APT_CUTOFF 325
+ scripts/config --set-val CONFIG_LRNG_IRQ_ENTROPY_RATE 256
+ scripts/config --enable CONFIG_LRNG_JENT
+ scripts/config --set-val CONFIG_LRNG_JENT_ENTROPY_RATE 16
+ scripts/config --enable CONFIG_LRNG_CPU
+ scripts/config --set-val CONFIG_LRNG_CPU_ENTROPY_RATE 8
+ scripts/config --enable CONFIG_LRNG_DRNG_SWITCH
+ scripts/config --enable CONFIG_LRNG_KCAPI_HASH
+ scripts/config --module CONFIG_LRNG_DRBG
+ scripts/config --module CONFIG_LRNG_KCAPI
+ scripts/config --enable CONFIG_LRNG_TESTING_MENU
+ scripts/config --disable CONFIG_LRNG_RAW_HIRES_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_JIFFIES_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_IRQ_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_IRQFLAGS_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_RETIP_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_REGS_ENTROPY
+ scripts/config --disable CONFIG_LRNG_RAW_ARRAY
+ scripts/config --disable CONFIG_LRNG_IRQ_PERF
+ scripts/config --disable CONFIG_LRNG_ACVT_HASH
+ scripts/config --enable CONFIG_LRNG_RUNTIME_ES_CONFIG
+ scripts/config --disable CONFIG_LRNG_RUNTIME_MAX_WO_RESEED_CONFIG
+ scripts/config --disable CONFIG_LRNG_TEST_CPU_ES_COMPRESSION
+ scripts/config --enable CONFIG_LRNG_SELFTEST
+ scripts/config --disable CONFIG_LRNG_SELFTEST_PANIC
+ fi
+
+ echo "Enable LLVM LTO"
+ if [ -n "$_use_llvm_lto" ]; then
+ scripts/config --disable CONFIG_LTO_NONE
+ fi
### Selecting the ZSTD compression level
if [ "$_zstd_level" = "ultra" ]; then
@@ -667,7 +666,7 @@ for _p in "${pkgname[@]}"; do
done
-md5sums=('b79700122766ccf561f032eb3c8da27e'
+md5sums=('5b04a1db6305c993d7f55db334a2b415'
'd97e86d9464dd34683f67de4d4a595c0'
'afdbe964cd00357ef7248553ab9db091'
'2627c6fcd9760b0e7a3553500db0a7e1'
@@ -689,7 +688,7 @@ md5sums=('b79700122766ccf561f032eb3c8da27e'
'8c354c3d1962ec6785db7f0c3fbbab03'
'9b6369bc4c58ad0d9195b5c204ed4b8a'
'c6efda5716e4ff79ebdbc963bebd851a'
- '408dfabb34f2b79aa2f5044b052703db'
+ '152706f6ebbe9917c6a5955cd5447344'
'08c84362cb916b30d9c77e35b1b3bc54'
'56fdf3562b041c0408d9751b7e447977'
'b09b84168822521426f197610727618b'