summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-09-20 16:14:22 +0200
committerPiotr Gorski2022-09-20 16:14:22 +0200
commitf8a09f47f83eb8f78292658c12a4328114cca7e0 (patch)
treef51c6c3acdd7d360cc6123f2dc6eefa9fcaac6c6
parentf5a1176d688a7cf5c1b39e0862b407ac842697f2 (diff)
downloadaur-f8a09f47f83eb8f78292658c12a4328114cca7e0.tar.gz
Bump to 5.19.10-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6070a85c50fd..8a08f5e71677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux BORE scheduler Kernel by CachyOS with other patches and improvements
- pkgver = 5.19.9
- pkgrel = 2
+ pkgver = 5.19.10
+ pkgrel = 1
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
@@ -21,15 +21,15 @@ pkgbase = linux-cacule
makedepends = make
makedepends = patch
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.9.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.19.10.tar.xz
source = config
source = auto-cpu-optimization.sh
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/all/0001-cachyos-base-all.patch
source = https://raw.githubusercontent.com/cachyos/kernel-patches/master/5.19/sched/0001-cacULE-cachy.patch
- sha256sums = 0ad5b5986693adc1962be807bc3a64423a24b6a9da9df39b259d7e3bfd927f37
+ sha256sums = 67dab932e85f9b9062ced666c8ea888230a1dadfd624b05aead6b6ebc6d3bdd5
sha256sums = 2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b
sha256sums = e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e
- sha256sums = 85aeec85cfeff447503c7c1f648c82764d22cecc57ce0b33338e7936c8282ee5
+ sha256sums = 37b05cf8cbefcc7660a548916ceba53adab153ef1202f49f465d02221fd4fa62
sha256sums = 13dc8ec85783b793ddd84472d6baef7154e964dacb179024fc7d0de493059b29
pkgname = linux-cacule
diff --git a/PKGBUILD b/PKGBUILD
index 6ae82e793f14..7b420c025e17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,6 +61,9 @@ _use_current=
### Enable KBUILD_CFLAGS -O3
_cc_harder=y
+### Set this to your number of threads you have in your machine otherwise it will default to 128
+_nr_cpus=
+
### Set performance governor as default
_per_gov=y
@@ -161,7 +164,7 @@ else
pkgbase=linux-$pkgsuffix
fi
_major=5.19
-_minor=9
+_minor=10
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -171,7 +174,7 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux BORE scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=1
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
@@ -421,6 +424,15 @@ prepare() {
--disable NEED_MULTIPLE_NODES
fi
+ ### Setting NR_CPUS
+ if [ -n "$_nr_cpus" ]; then
+ echo "Setting custom NR_CPUS..."
+ scripts/config --set-val NR_CPUS "$_nr_cpus"
+ else
+ echo "Setting default NR_CPUS..."
+ scripts/config --set-val NR_CPUS 128
+ fi
+
### Disable MQ Deadline I/O scheduler
if [ -n "$_mq_deadline_disable" ]; then
echo "Disabling MQ-Deadline I/O scheduler..."
@@ -936,8 +948,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('0ad5b5986693adc1962be807bc3a64423a24b6a9da9df39b259d7e3bfd927f37'
+sha256sums=('67dab932e85f9b9062ced666c8ea888230a1dadfd624b05aead6b6ebc6d3bdd5'
'2c23daf5bd0dadda120cb6d237f1728130fe3f2bff81a70b3871fa044f74d82b'
'e1d45b5842079a5f0f53d7ea2d66ffa3f1497766f3ccffcf13ed00f1ac67f95e'
- '85aeec85cfeff447503c7c1f648c82764d22cecc57ce0b33338e7936c8282ee5'
+ '37b05cf8cbefcc7660a548916ceba53adab153ef1202f49f465d02221fd4fa62'
'13dc8ec85783b793ddd84472d6baef7154e964dacb179024fc7d0de493059b29')