summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.Jung2021-09-29 17:21:28 +0000
committerP.Jung2021-09-29 17:21:28 +0000
commitfec1891a5501b62da38832e3a3a2b5cf4f40e66f (patch)
treeffe1f531d88584d8e0dfcc6527ee76b01901367c
parent27ea66b28a927077195c11432838255946b956eb (diff)
downloadaur-fec1891a5501b62da38832e3a3a2b5cf4f40e66f.tar.gz
makedepends fixed, lto fixed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--config2
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc521ab89382..b4eb7b3a9842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule
pkgdesc = Linux-CacULE Kernel by Hamad Marri and with some other patchsets
pkgver = 5.14.8
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ptr1337/linux-cacule
arch = x86_64
arch = x86_64_v3
@@ -49,7 +49,7 @@ pkgbase = linux-cacule
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/0001-ksm.patch
source = auto-cpu-optimization.sh
md5sums = ce6434b646ade20e292fb28c1aacde58
- md5sums = c1d4b49a8699d4d527704758130d4f9b
+ md5sums = 6cfe7a16a5260cb75e5a4145991e0027
md5sums = ef749be7f2048456ae738f93229bf354
md5sums = 40a9380b2884f5d417791f06389ba57e
md5sums = 430972ae1e936f99d8dc2a1f4fdaf774
diff --git a/PKGBUILD b/PKGBUILD
index 8ebe0a75badf..eb8a644f95df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,6 +34,7 @@ _kyber_disable=y
### Enable protect file mappings under memory pressure
_mm_protect=y
+
_lru_enable=y
### Enable Linux Random Number Generator
@@ -85,7 +86,7 @@ pkgbase=linux-cacule
pkgname=('linux-cacule' 'linux-cacule-headers')
pkgname=("${pkgbase}" "${pkgbase}-headers")
pkgver=5.14.8
-pkgrel=3
+pkgrel=4
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-CacULE Kernel by Hamad Marri and with some other patchsets'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -95,6 +96,9 @@ license=('GPL2')
options=('!strip')
makedepends=('kmod' 'bc' 'libelf' 'python-sphinx' 'python-sphinx_rtd_theme'
'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz')
+if [ -n "$_use_llvm_lto" ]; then
+makedepends+=(clang llvm lld python)
+fi
_caculepatches="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE"
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14"
source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver}.tar.xz"
@@ -103,10 +107,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver
"${_patchsource}/arch-patches-v8/0001-arch-patches.patch"
"${_caculepatches}/v5.14/cacule-5.14.patch"
# "${_patchsource}/misc/0004-folio-mm.patch"
-# "${_patchsource}/misc/amd/0011-amd-ptdma.patch"
"${_patchsource}/misc/amd/0006-amd-cppc.patch"
-# "${_patchsource}/misc/0007-string.patch"
-# "${_patchsource}/0001-Allow-polling-rate-to-be-set-for-all-usb-devices.patch"
"${_patchsource}/misc/zen-tweaks-cacule.patch"
"${_patchsource}/ll-patches/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
"${_patchsource}/ll-patches/0003-sched-core-nr_migrate-256-increases-number-of-tasks-.patch"
@@ -394,9 +395,12 @@ prepare() {
scripts/config --enable CONFIG_NTFS3_FS_POSIX_ACL
### miscellaneous ###
scripts/config --enable CONFIG_ZEN_INTERACTIVE
+ echo "Enable AMD PSTATE"
scripts/config --enable CONFIG_x86_AMD_PSTATE
- scripts/config --enable CONFIG_LTO_NONE
-
+ echo "Enable LLVM LTO"
+ if [ -n "$_use_llvm_lto" ]; then
+ scripts/config --disable CONFIG_LTO_NONE
+ fi
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
if [ -n "$_use_current" ]; then
@@ -564,7 +568,7 @@ package_linux-cacule-headers() {
}
md5sums=('ce6434b646ade20e292fb28c1aacde58'
- 'c1d4b49a8699d4d527704758130d4f9b'
+ '6cfe7a16a5260cb75e5a4145991e0027'
'ef749be7f2048456ae738f93229bf354'
'40a9380b2884f5d417791f06389ba57e'
'430972ae1e936f99d8dc2a1f4fdaf774'
diff --git a/config b/config
index 18eee60e75f0..c1016d8e0405 100644
--- a/config
+++ b/config
@@ -883,7 +883,7 @@ CONFIG_LTO_CLANG=y
CONFIG_ARCH_SUPPORTS_LTO_CLANG=y
CONFIG_ARCH_SUPPORTS_LTO_CLANG_THIN=y
CONFIG_HAS_LTO_CLANG=y
-# CONFIG_LTO_NONE is not set
+CONFIG_LTO_NONE=y
CONFIG_LTO_CLANG_THIN=y
# CONFIG_LTO_CLANG_FULL is not set
CONFIG_HAVE_ARCH_WITHIN_STACK_FRAMES=y