summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.Jung2021-08-18 10:41:57 +0000
committerP.Jung2021-08-18 10:41:57 +0000
commit49c2a8e25fb75c7820e3f7af13d072cd8581d8f7 (patch)
treedd711daa14d0c06dac00dc866ece07a37ab9b4ce
parentf4475adfda95e3ecb5fe9c8332efdca228452402 (diff)
downloadaur-49c2a8e25fb75c7820e3f7af13d072cd8581d8f7.tar.gz
5.13.12
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--configure263
3 files changed, 281 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46ab80ace218..09407967042e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule-rdb-llvm
pkgdesc = Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets with FULL LTO optimization
- pkgver = 5.13.11
- pkgrel = 3
+ pkgver = 5.13.12
+ pkgrel = 1
url = https://github.com/hamadmarri/cacule-cpu-scheduler
arch = x86_64
arch = x86_64_v3
@@ -24,7 +24,7 @@ pkgbase = linux-cacule-rdb-llvm
makedepends = python
makedepends = llvm-libs
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.11.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.12.tar.xz
source = config
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/arch-patches-v5/0001-arch-patches.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/CacULE/v5.13/cacule-5.13.patch
@@ -52,7 +52,7 @@ pkgbase = linux-cacule-rdb-llvm
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/clearlinux-patches-v2/0001-clearlinux-patches.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/v4l2loopback-patches-v2/0001-v4l2loopback-patches.patch
source = auto-cpu-optimization.sh
- md5sums = 89020a90124a6798054a03c7a2ead059
+ md5sums = 6e1728b2021ca19cc9273f080e6c44c7
md5sums = 8523a8d066c08f037621ec101a6b87fd
md5sums = 9f9b916ed39dc125db45d0bff672f4c0
md5sums = 078da517ec2d54283af81d7da3af671a
@@ -94,5 +94,5 @@ pkgname = linux-cacule-rdb-llvm
pkgname = linux-cacule-rdb-llvm-headers
pkgdesc = Headers and scripts for building modules for the Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets with FULL LTO optimization
- depends = linux-cacule-rdb-llvm=5.13.11
+ depends = linux-cacule-rdb-llvm=5.13.12
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 9469c4af6fa3..c824f3b47a3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,9 +26,10 @@ use_selinux=n
use_tomoyo=n
use_yama=n
use_apparmor=
-## Apply Kernel Optimization
+## Apply Kernel automatic Optimization
_use_optimization=y
-
+## Apply Kernel Optimization selecting
+_use_optimizatio_select=
# Only compile active modules to VASTLY reduce the number of modules built and
# the build time.
#
@@ -50,8 +51,8 @@ _use_current=
pkgbase=linux-cacule-rdb-llvm
pkgname=("${pkgbase}" "${pkgbase}-headers")
-pkgver=5.13.11
-pkgrel=3
+pkgver=5.13.12
+pkgrel=1
_gittag=v${pkgver%.*}-${pkgver##*.}
pkgdesc='Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets with FULL LTO optimization'
arch=('x86_64' 'x86_64_v3')
@@ -128,6 +129,13 @@ prepare() {
if [ -n "$_use_optimization" ]; then
sh "${srcdir}"/auto-cpu-optimization.sh
fi
+
+ if [ -n "$_use_optimization_select" ]; then
+ source "${startdir}"/configure
+
+ cpu_arch
+ fi
+
### Optionally set tickrate to 2000HZ
if [ -n "$_2k_HZ_ticks" ]; then
echo "Setting tick rate to 2k..."
@@ -430,7 +438,7 @@ package_linux-cacule-rdb-llvm-headers() {
}
-md5sums=('89020a90124a6798054a03c7a2ead059'
+md5sums=('6e1728b2021ca19cc9273f080e6c44c7'
'8523a8d066c08f037621ec101a6b87fd'
'9f9b916ed39dc125db45d0bff672f4c0'
'078da517ec2d54283af81d7da3af671a'
diff --git a/configure b/configure
new file mode 100644
index 000000000000..2f1411ccbfa4
--- /dev/null
+++ b/configure
@@ -0,0 +1,263 @@
+#!/usr/bin/bash
+
+cpu_arch() {
+ plain ""
+ plain "#########################################"
+ plain "Set cpu microarchitecture optimization in GCC"
+ read -rp "`echo $' > 1) M486SX : Select this for an 486-class CPU without an FPU such as AMD/Cyrix/IBM/Intel SL/SLC/SLC2/SLC3/SX/SX2 and UMC U5S.\n \
+ > 2) M486 : Select this for an 486-class CPU such as AMD/Cyrix/IBM/Intel 486DX/DX2/DX4 and UMC U5D.\n \
+ > 3) M586 : Select this for an 586 or 686 series processor such as the AMD K5,the Cyrix 5x86, 6x86 and 6x86MX. This choice does not assume the RDTSC (Read Time Stamp Counter) instruction.\n \
+ > 4) M586TSC : Select this for a Pentium Classic processor with the RDTSC (Read Time Stamp Counter) instruction for benchmarking.\n \
+ > 5) M586MMX : Select this for a Pentium with the MMX graphics/multimedia extended instructions.\n \
+ > 6) M686 : Select this for Intel Pentium Pro chips.\n \
+ > 7) MPENTIUMII : Select this for Intel chips based on the Pentium-II and pre-Coppermine Celeron core.\n \
+ > 8) MPENTIUMIII : Select this for Intel chips based on the Pentium-III and Celeron-Coppermine core.\n \
+ > 9) MPENTIUMM : Select this for Intel Pentium M (not Pentium-4 M) notebook chips.\n \
+ > 10) MPENTIUM4 : Select this for Intel Pentium 4 chips.\n \
+ > 11) MK6 : Select this for an AMD K6-family processor.\n \
+ > 12) MK7 : Select this for an AMD Athlon K7-family processor.\n \
+ > 13) MK8 : Select this for an AMD Opteron or Athlon64 Hammer-family processor.\n \
+ > 14) MK8SSE3 : Select this for improved AMD Opteron or Athlon64 Hammer-family processors.\n \
+ > 15) MK10 : Select this for an AMD 61xx Eight-Core Magny-Cours, Athlon X2 7x50,Phenom X3/X4/II, Athlon II X2/X3/X4, or Turion II-family processor.\n \
+ > 16) MBARCELONA : Select this for AMD Family 10h Barcelona processors.\n \
+ > 17) MBOBCAT : Select this for AMD Family 14h Bobcat processors.\n \
+ > 18) MJAGUAR : Select this for AMD Family 16h Jaguar processors.\n \
+ > 19) MBULLDOZER : Select this for AMD Family 15h Bulldozer processors.\n \
+ > 20) MPILEDRIVER : Select this for AMD Family 15h Piledriver processors.\n \
+ > 21) MSTEAMROLLER : Select this for AMD Family 15h Steamroller processors.\n \
+ > 22) MEXCAVATOR : Select this for AMD Family 15h Excavator processors.\n \
+ > 23) MZEN : Select this for AMD Family 17h Zen processors.\n \
+ > 24) MZEN2 : Select this for AMD Family 17h Zen 2 processors.\n \
+ > 25) MZEN3 : Select this for AMD Family 19h Zen 3 processors. - GCC 10.3 required\n \
+ > 26) MCRUSOE : Select this for a Transmeta Crusoe processor.\n \
+ > 27) MEFFICEON : Select this for a Transmeta Efficeon processor.\n \
+ > 28) MWINCHIPC6 : Select this for an IDT Winchip C6 chip.\n \
+ > 29) MWINCHIP3D : Select this for an IDT Winchip-2, 2A or 3.\n \
+ > 30) MELAN : Select this for an AMD Elan processor.\n \
+ > 31) MGEODEGX1 : Select this for a Geode GX1 (Cyrix MediaGX) chip.\n \
+ > 32) MGEODE_LX Select this for AMD Geode GX and LX processors.\n \
+ > 33) MCYRIXIII : Select this for a Cyrix III or C3 chip.\n \
+ > 34) MVIAC3_2 : Select this for a VIA C3 "Nehemiah".\n \
+ > 35) MVIAC7 : Select this for a VIA C7.\n \
+ > 36) MPSC : Optimize for Intel Pentium 4, Pentium D and older Nocona/Dempsey Xeon CPUs with Intel 64bit which is compatible with x86-64.\n \
+ > 37) MATOM : Select this for the Intel Atom platform.\n \
+ > 38) MCORE2 : Select this for Intel Core 2 and newer Core 2 Xeons (Xeon 51xx and 53xx) CPUs.\n \
+ > 39) MNEHALEM : Select this for 1st Gen Core processors in the Nehalem family.\n \
+ > 40) MWESTMERE : Select this for the Intel Westmere formerly Nehalem-C family.\n \
+ > 41) MSILVERMONT Select this for the Intel Silvermont platform.\n \
+ > 42) MGOLDMONT : Select this for the Intel Goldmont platform including Apollo Lake and Denverton.\n \
+ > 43) MGOLDMONTPLUS : Select this for the Intel Goldmont Plus platform including Gemini Lake.\n \
+ > 44) MSANDYBRIDGE : Select this for 2nd Gen Core processors in the Sandy Bridge family.\n \
+ > 45) MIVYBRIDGE : Select this for 3rd Gen Core processors in the Ivy Bridge family.\n \
+ > 46) MHASWELL : Select this for 4th Gen Core processors in the Haswell family.\n \
+ > 47) MBROADWELL : Select this for 5th Gen Core processors in the Broadwell family.\n \
+ > 48) MSKYLAKE : Select this for 6th Gen Core processors in the Skylake family.\n \
+ > 49) MSKYLAKEX : Select this for 6th Gen Core processors in the Skylake X family.\n \
+ > 50) MCANNONLAKE : Select this for 8th Gen Core processors.\n \
+ > 51) MICELAKE : Select this for 10th Gen Core processors in the Ice Lake family.\n \
+ > 52) MCASCADELAKE : Select this for Xeon processors in the Cascade Lake family.\n \
+ > 53) MCOOPERLAKE : Select this for Xeon processors in the Cooper Lake family. - GCC 10.1 required\n \
+ > 54) MTIGERLAKE : Select this for third-generation 10 nm process processors in the Tiger Lake family. - GCC 10.1 required\n \
+ > 55) MSAPPHIRERAPIDS : Select this for third-generation 10 nm process processors in the Sapphire Rapids family. - GCC 11 required\n \
+ > 56) MALDERLAKE : Select this for twelfth-generation processors in the Alder Lake family.- GCC 11 required\n \
+ > 57) GENERIC_CPU : Generic x86-64 CPU. Run equally well on all x86-64 CPUs.\n \
+ > 58) GENERIC_CPU2 : Run equally well on all x86-64 CPUs with min support of x86-64-v2. - GCC 11 required\n \
+ > 59) GENERIC_CPU3 : Generic x86-64-v3 CPU with v3 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v3. - GCC 11 required\n \
+ > 60) GENERIC_CPU4 : Generic x86-64 CPU with v4 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v4. - GCC 11 required\n \
+ > 61) MNATIVE_INTEL : Intel-Native optimizations autodetected by GCC.\n \
+ > 62) MNATIVE_AMD : AMD-Native optimizations autodetected by GCC.\n \
+ > Default (57 : Gneric CPU)\nchoice[0-62]: '`" _microarchitecture
+
+ if [[ "$_microarchitecture" = "1" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "2" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "3" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586
+ elif [[ "$_microarchitecture" = "4" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586TSC
+ elif [[ "$_microarchitecture" = "5" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586MMX
+ elif [[ "$_microarchitecture" = "6" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M686
+ elif [[ "$_microarchitecture" = "7" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMII
+ elif [[ "$_microarchitecture" = "8" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMIII
+ elif [[ "$_microarchitecture" = "9" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMM
+ elif [[ "$_microarchitecture" = "10" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUM4
+ elif [[ "$_microarchitecture" = "11" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK6
+ elif [[ "$_microarchitecture" = "12" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK7
+ elif [[ "$_microarchitecture" = "13" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8
+ elif [[ "$_microarchitecture" = "14" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8SSE3
+ elif [[ "$_microarchitecture" = "15" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK10
+ elif [[ "$_microarchitecture" = "16" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBARCELONA
+ elif [[ "$_microarchitecture" = "17" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBOBCAT
+ elif [[ "$_microarchitecture" = "18" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MJAGUAR
+ elif [[ "$_microarchitecture" = "19" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBULLDOZER
+ elif [[ "$_microarchitecture" = "20" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPILEDRIVER
+ elif [[ "$_microarchitecture" = "21" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSTEAMROLLER
+ elif [[ "$_microarchitecture" = "22" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEXCAVATOR
+ elif [[ "$_microarchitecture" = "23" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN
+ elif [[ "$_microarchitecture" = "24" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN2
+ elif [[ "$_microarchitecture" = "25" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN3
+ elif [[ "$_microarchitecture" = "26" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCRUSOE
+ elif [[ "$_microarchitecture" = "27" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEFFICEON
+ elif [[ "$_microarchitecture" = "28" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIPC6
+ elif [[ "$_microarchitecture" = "29" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIP3D
+ elif [[ "$_microarchitecture" = "30" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MELAN
+ elif [[ "$_microarchitecture" = "31" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODEGX1
+ elif [[ "$_microarchitecture" = "32" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODE_LX
+ elif [[ "$_microarchitecture" = "33" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCYRIXIII
+ elif [[ "$_microarchitecture" = "34" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC3_2
+ elif [[ "$_microarchitecture" = "35" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC7
+ elif [[ "$_microarchitecture" = "36" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPSC
+ elif [[ "$_microarchitecture" = "37" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MATOM
+ elif [[ "$_microarchitecture" = "38" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCORE2
+ elif [[ "$_microarchitecture" = "39" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNEHALEM
+ elif [[ "$_microarchitecture" = "40" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWESTMERE
+ elif [[ "$_microarchitecture" = "41" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSILVERMONT
+ elif [[ "$_microarchitecture" = "42" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONT
+ elif [[ "$_microarchitecture" = "43" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONTPLUS
+ elif [[ "$_microarchitecture" = "44" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSANDYBRIDGE
+ elif [[ "$_microarchitecture" = "45" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MIVYBRIDGE
+ elif [[ "$_microarchitecture" = "46" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MHASWELL
+ elif [[ "$_microarchitecture" = "47" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBROADWELL
+ elif [[ "$_microarchitecture" = "48" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKE
+ elif [[ "$_microarchitecture" = "49" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKEX
+ elif [[ "$_microarchitecture" = "50" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCANNONLAKE
+ elif [[ "$_microarchitecture" = "51" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MICELAKE
+ elif [[ "$_microarchitecture" = "52" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCASCADELAKE
+ elif [[ "$_microarchitecture" = "53" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCOOPERLAKE
+ elif [[ "$_microarchitecture" = "54" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MTIGERLAKE
+ elif [[ "$_microarchitecture" = "55" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSAPPHIRERAPIDS
+ elif [[ "$_microarchitecture" = "56" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MALDERLAKE
+ elif [[ "$_microarchitecture" = "57" ]]; then
+ scripts/config --enable CONFIG_GENERIC_CPU
+ elif [[ "$_microarchitecture" = "58" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU2
+ elif [[ "$_microarchitecture" = "59" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU3
+ elif [[ "$_microarchitecture" = "60" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU4
+ elif [[ "$_microarchitecture" = "61" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_INTEL
+ elif [[ "$_microarchitecture" = "62" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_AMD
+ else
+ scripts/config --enable CONFIG_GENERIC_CPU
+ fi
+
+ plain ""
+
+ sleep 2
+}