summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptr13372021-09-16 06:37:18 +0000
committerptr13372021-09-16 06:37:18 +0000
commit7d7bead04795a56f21597d316c77479025db99f8 (patch)
tree6c7d7bff533ace9e83866f0ff9f79f5ce6e63dda
parent8203390226c783d60edca96a8c68c8557ea70b10 (diff)
downloadaur-7d7bead04795a56f21597d316c77479025db99f8.tar.gz
fixes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34f3f702e4cf..1395449f9da7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule-rdb-llvm
pkgdesc = Linux-CacULE Kernel-RDB by Hamad Marri and with some other patchsets compiled with FULL-LTO
pkgver = 5.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ptr1337/linux-cacule
arch = x86_64
arch = x86_64_v3
@@ -21,16 +21,19 @@ pkgbase = linux-cacule-rdb-llvm
makedepends = llvm
makedepends = llvm-libs
makedepends = lld
+ makedepends = clang
+ makedepends = compiler-rt
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.4.tar.xz
source = config
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/arch-patches-v4/0001-arch-patches.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/arch-patches-v5/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE/v5.14/cacule-5.14-full.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0004-folio-mm.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0007-string.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/allpollingrate.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/0001-AMD-CPPC.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/misc/zen-tweaks-cacule.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/bfq-patches-v2/0001-bfq-patches.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch
source = https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch
@@ -55,13 +58,14 @@ pkgbase = linux-cacule-rdb-llvm
source = auto-cpu-optimization.sh
md5sums = 3208dd1c05a8542865a1795cdc5b8cec
md5sums = 1c0a09a4686636c79fbc0237a7a6ed3f
- md5sums = 54e7291aee96376a49ab3ba74d3e47f0
+ md5sums = 9abde29217354c69925d2bc672f66d67
md5sums = 024a0126cfcd18e000a2241f35c4d69e
md5sums = a804260e2f301ffe2a17d6e3625a9711
md5sums = d6e5581b4fade267a28deb8e73d236f5
md5sums = f154315498da9bf593c11d88041bde48
md5sums = f8e172e9ea554bbb1053eb122c3ace35
md5sums = 302cbad3c979395f37307a094f6d8fd5
+ md5sums = 9d7612159f8745044254077ce8a76df6
md5sums = 58eab1d2000ac3fa1d6ab933b13397cc
md5sums = e45c7962a78d6e82a0d3808868cd6ac0
md5sums = 196d6ac961497aa880264b83160eb140
diff --git a/PKGBUILD b/PKGBUILD
index 78366a2aaf48..04b45b073e33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,7 +82,7 @@ pkgbase=linux-cacule-rdb-llvm
pkgname=('linux-cacule-rdb-llvm' 'linux-cacule-rdb-llvm-headers')
pkgname=("${pkgbase}" "${pkgbase}-headers")
pkgver=5.14.4
-pkgrel=1
+pkgrel=2
arch=(x86_64 x86_64_v3)
pkgdesc='Linux-CacULE Kernel-RDB by Hamad Marri and with some other patchsets compiled with FULL-LTO'
_gittag=v${pkgver%.*}-${pkgver##*.}
@@ -91,19 +91,20 @@ url="https://github.com/ptr1337/linux-cacule"
license=('GPL2')
options=('!strip')
makedepends=('kmod' 'bc' 'libelf' 'python-sphinx' 'python-sphinx_rtd_theme'
- 'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'llvm' 'llvm-libs' 'lld')
+ 'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'llvm' 'llvm-libs' 'lld' 'clang' 'compiler-rt')
_caculepatches="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/CacULE"
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/5.14"
source=("https://cdn.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-${pkgver}.tar.xz"
"config"
-# "${_patchsource}/arch-patches/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
- "${_patchsource}/arch-patches-v4/0001-arch-patches.patch"
+ "${_patchsource}/arch-patches-v5/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch"
+# "${_patchsource}/arch-patches-v4/0001-arch-patches.patch"
"${_caculepatches}/v5.14/cacule-5.14-full.patch"
"${_patchsource}/misc/0004-folio-mm.patch"
"${_patchsource}/misc/0007-string.patch"
"${_patchsource}/misc/allpollingrate.patch"
"${_patchsource}/misc/0001-LL-kconfig-add-750Hz-timer-interrupt-kernel-config-o.patch"
"${_patchsource}/misc/0001-AMD-CPPC.patch"
+ "${_patchsource}/misc/zen-tweaks-cacule.patch"
"${_patchsource}/bfq-patches-v2/0001-bfq-patches.patch"
"${_patchsource}/android-patches/0001-android-export-symbold-and-enable-building-ashmem-an.patch"
"${_patchsource}/bbr2-patches/0001-bbr2-5.14-introduce-BBRv2.patch"
@@ -555,13 +556,14 @@ package_linux-cacule-rdb-llvm-headers() {
md5sums=('3208dd1c05a8542865a1795cdc5b8cec'
'1c0a09a4686636c79fbc0237a7a6ed3f'
- '54e7291aee96376a49ab3ba74d3e47f0'
+ '9abde29217354c69925d2bc672f66d67'
'024a0126cfcd18e000a2241f35c4d69e'
'a804260e2f301ffe2a17d6e3625a9711'
'd6e5581b4fade267a28deb8e73d236f5'
'f154315498da9bf593c11d88041bde48'
'f8e172e9ea554bbb1053eb122c3ace35'
'302cbad3c979395f37307a094f6d8fd5'
+ '9d7612159f8745044254077ce8a76df6'
'58eab1d2000ac3fa1d6ab933b13397cc'
'e45c7962a78d6e82a0d3808868cd6ac0'
'196d6ac961497aa880264b83160eb140'