summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP.Jung2021-08-18 02:06:58 +0000
committerP.Jung2021-08-18 02:06:58 +0000
commitf4475adfda95e3ecb5fe9c8332efdca228452402 (patch)
tree813b3e284c2f2226bc14d84558be8b4ced145b9d
parentc5a967c34ccd9a8dc6066dd2eb32ea9279e7266a (diff)
downloadaur-f4475adfda95e3ecb5fe9c8332efdca228452402.tar.gz
cpu patches updated, autodetection fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b397a090ab4..46ab80ace218 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-cacule-rdb-llvm
pkgdesc = Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets with FULL LTO optimization
pkgver = 5.13.11
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hamadmarri/cacule-cpu-scheduler
arch = x86_64
arch = x86_64_v3
@@ -28,7 +28,7 @@ pkgbase = linux-cacule-rdb-llvm
source = config
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/arch-patches-v5/0001-arch-patches.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/CacULE/v5.13/cacule-5.13.patch
- source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/cpu-patches/0001-cpu-patches.patch
+ source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/cpu-patches-v2/0001-cpu-patches.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/futex-patches/0001-futex-resync-from-gitlab.collabora.com.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/futex2-xanmod-patches-v3/0001-futex2-resync-from-gitlab.collabora.com.patch
source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.13/winesync/5.13-winesync.patch
@@ -56,7 +56,7 @@ pkgbase = linux-cacule-rdb-llvm
md5sums = 8523a8d066c08f037621ec101a6b87fd
md5sums = 9f9b916ed39dc125db45d0bff672f4c0
md5sums = 078da517ec2d54283af81d7da3af671a
- md5sums = 7640a753a7803248543675a6edc75e08
+ md5sums = 8d5925f0d8f42fd4c5ed46acfbf86492
md5sums = 85f4be6562ee033b83814353a12b61bd
md5sums = 3ec9a8784a9e73462def2e9c33de9a1e
md5sums = 9573b92353399343db8a691c9b208300
diff --git a/PKGBUILD b/PKGBUILD
index 2d1c3f9d08e0..9469c4af6fa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,8 @@ use_selinux=n
use_tomoyo=n
use_yama=n
use_apparmor=
+## Apply Kernel Optimization
+_use_optimization=y
# Only compile active modules to VASTLY reduce the number of modules built and
# the build time.
@@ -49,7 +51,7 @@ _use_current=
pkgbase=linux-cacule-rdb-llvm
pkgname=("${pkgbase}" "${pkgbase}-headers")
pkgver=5.13.11
-pkgrel=2
+pkgrel=3
_gittag=v${pkgver%.*}-${pkgver##*.}
pkgdesc='Linux-CacULE-RDB Kernel by Hamad Marri and with some other patchsets with FULL LTO optimization'
arch=('x86_64' 'x86_64_v3')
@@ -65,7 +67,7 @@ source=(
"config"
"${_patchsource}/arch-patches-v5/0001-arch-patches.patch"
"${_caculepatches}/v5.13/cacule-5.13.patch"
- "${_patchsource}/cpu-patches/0001-cpu-patches.patch"
+ "${_patchsource}/cpu-patches-v2/0001-cpu-patches.patch"
"${_patchsource}/futex-patches/0001-futex-resync-from-gitlab.collabora.com.patch"
"${_patchsource}/futex2-xanmod-patches-v3/0001-futex2-resync-from-gitlab.collabora.com.patch"
"${_patchsource}/winesync/5.13-winesync.patch"
@@ -122,9 +124,10 @@ prepare() {
echo "Setting config..."
cp ../config .config
- # Let's user choose microarchitecture optimization in GCC
- sh "${srcdir}"/auto-cpu-optimization.sh
-
+ ### Microarchitecture Optimization (GCC/CLANG)
+ if [ -n "$_use_optimization" ]; then
+ sh "${srcdir}"/auto-cpu-optimization.sh
+ fi
### Optionally set tickrate to 2000HZ
if [ -n "$_2k_HZ_ticks" ]; then
echo "Setting tick rate to 2k..."
@@ -431,7 +434,7 @@ md5sums=('89020a90124a6798054a03c7a2ead059'
'8523a8d066c08f037621ec101a6b87fd'
'9f9b916ed39dc125db45d0bff672f4c0'
'078da517ec2d54283af81d7da3af671a'
- '7640a753a7803248543675a6edc75e08'
+ '8d5925f0d8f42fd4c5ed46acfbf86492'
'85f4be6562ee033b83814353a12b61bd'
'3ec9a8784a9e73462def2e9c33de9a1e'
'9573b92353399343db8a691c9b208300'