summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2018-11-23 06:47:32 -0500
committergraysky2018-11-23 06:47:32 -0500
commit86aad8b161dec59d527ead1eaa1788e982321073 (patch)
tree81a72092ff037b22a0b759503c46b3b95cb28fb5
parentc5e5dd0f2f86f5d4b77493749e0be25481c7c700 (diff)
downloadaur-86aad8b161dec59d527ead1eaa1788e982321073.tar.gz
Update to 4.19.4-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2e007a57746..16727b7b5907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Wed Nov 21 19:10:57 UTC 2018
+# Fri Nov 23 11:47:32 UTC 2018
pkgbase = linux-ck
- pkgver = 4.19.3
+ pkgver = 4.19.4
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = linux-ck
makedepends = bc
makedepends = libelf
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.3.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.3.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.4.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.4.tar.sign
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -20,7 +20,7 @@ pkgbase = linux-ck
source = enable_additional_cpu_optimizations-20180509.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20180509.tar.gz
source = http://ck.kolivas.org/patches/4.0/4.19/4.19-ck1/patch-4.19-ck1.xz
source = 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- sha256sums = 1e3c5712d4d0fdf307cf6b69d220f8e54def487e41efb0fbabe652a7a9986420
+ sha256sums = a38f5606bba1f5611c798541f6c3d43267b8599d9e3167471d4b662e33ff47aa
sha256sums = SKIP
sha256sums = e296d89203a7688d69ec94d0c31e95ab83094a6f24f3c53104b3f19954d9e7dc
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
@@ -38,12 +38,12 @@ pkgname = linux-ck
depends = kmod
depends = mkinitcpio
optdepends = crda: to set the correct wireless channels of your country
- provides = linux-ck=4.19.3
+ provides = linux-ck=4.19.4
backup = etc/mkinitcpio.d/linux-ck.preset
pkgname = linux-ck-headers
pkgdesc = Header files and scripts for building modules for Linux-ck kernel
depends = linux-ck
- provides = linux-ck-headers=4.19.3
- provides = linux-headers=4.19.3
+ provides = linux-ck-headers=4.19.4
+ provides = linux-headers=4.19.4
diff --git a/PKGBUILD b/PKGBUILD
index 44c48c095150..f3591a358107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,7 +69,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-_srcver=4.19.3-arch1
+_srcver=4.19.4-arch1
pkgver=${_srcver%-*}
pkgrel=1
_ckpatchversion=1
@@ -94,7 +94,7 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('1e3c5712d4d0fdf307cf6b69d220f8e54def487e41efb0fbabe652a7a9986420'
+sha256sums=('a38f5606bba1f5611c798541f6c3d43267b8599d9e3167471d4b662e33ff47aa'
'SKIP'
'e296d89203a7688d69ec94d0c31e95ab83094a6f24f3c53104b3f19954d9e7dc'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
@@ -204,13 +204,18 @@ _package() {
cd linux-${pkgver}
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"