summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantman6662021-08-06 22:58:27 +0800
committerantman6662021-08-06 22:58:27 +0800
commit418eeda5e69805891a336a096bcad352f0be4be5 (patch)
tree0bd1cba65cd2fb33ca8560853e0b2b7196977597
parentcde8041f5b3eb4da35b2e3000db5e958e80666cd (diff)
downloadaur-418eeda5e69805891a336a096bcad352f0be4be5.tar.gz
random update somethings
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a1b29b014e8..4d211342fde9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,6 +63,7 @@ _localmodcfg=
# 39. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL) (NEW)
# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD) (NEW)
+## It will select by itself
if [ -z ${_subarch+x} ]; then
cpu=`grep vendor_id /proc/cpuinfo | awk -F: '{print $2}' | tail -1`
if [ $cpu == 'GenuineIntel' ]; then
@@ -176,6 +177,9 @@ prepare() {
# https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
scripts/config --disable CONFIG_KVM_WERROR
+ scripts/config --enable CONFIG_FTRACE
+ scripts/config --enable CONFIG_FTRACE_SYSCALLS
+
# fix naming schema in EXTRAVERSION of ck patch set
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"