summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-12-19 14:06:19 +0100
committerJosip Ponjavic2019-12-19 14:06:19 +0100
commit969f7b4a113ac9bb52129dafe910a651ef16c1b3 (patch)
tree9d85a628911cc8d4b0b79fcb334c2c0d8690a1dd
parent46c3c44e11f3c3fd8016579e96a1ef716af39ac9 (diff)
downloadaur-969f7b4a113ac9bb52129dafe910a651ef16c1b3.tar.gz
5.4.5-3 (clr 5.4.4-879) add latest wireguard source and fix build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cba9f7f523d7..ad39b52bedd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = linux-clear
pkgdesc = Clear Linux
pkgver = 5.4.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/clearlinux-pkgs/linux
arch = x86_64
license = GPL2
makedepends = bc
makedepends = cpio
makedepends = git
- makedepends = inetutils
makedepends = kmod
makedepends = libelf
makedepends = xmlto
@@ -17,6 +16,7 @@ pkgbase = linux-clear
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.sign
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.4.5.xz
source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=5.4.4-879
+ source = https://git.zx2c4.com/WireGuard/snapshot/WireGuard-0.0.20191219.tar.xz
source = enable_additional_cpu_optimizations-20190822.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20190822.tar.gz
source = pci-enable-overrides-for-missing-acs-capabilities.patch
source = futex-wait-multiple-5.2.1.patch::https://aur.archlinux.org/cgit/aur.git/plain/futex-wait-multiple-5.2.1.patch?h=linux-fsync
@@ -28,6 +28,7 @@ pkgbase = linux-clear
sha256sums = SKIP
sha256sums = 7ac5c8967fb99aa379148c1edd7bc98689972fecf916e77954cd36328f85b260
sha256sums = SKIP
+ sha256sums = 5aba6f0c38e97faa0b155623ba594bb0e4bd5e29deacd8d5ed8bda8d8283b0e7
sha256sums = 8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5
sha256sums = 4127910703ed934224941114c2a4e0bcc5b4841f46d04063ed7b20870a51baa0
sha256sums = b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942
diff --git a/PKGBUILD b/PKGBUILD
index 37e367dc9bd8..f6890e208e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,19 +64,21 @@ _srcname=linux-${_major}
_clr=${_major}.4-879
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=2
+pkgrel=3
pkgdesc='Clear Linux'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
-makedepends=('bc' 'cpio' 'git' 'inetutils' 'kmod' 'libelf' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
+_wrg_snap='0.0.20191219'
_gcc_more_v='20190822'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.xz"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.sign"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=${_clr}"
+ "https://git.zx2c4.com/WireGuard/snapshot/WireGuard-${_wrg_snap}.tar.xz"
"enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
'pci-enable-overrides-for-missing-acs-capabilities.patch'
'futex-wait-multiple-5.2.1.patch::https://aur.archlinux.org/cgit/aur.git/plain/futex-wait-multiple-5.2.1.patch?h=linux-fsync'
@@ -102,11 +104,15 @@ prepare() {
echo "${pkgbase#linux}" > localversion.20-pkgname
### Add Clearlinux patches
- for i in $(grep '^Patch' ${srcdir}/clearlinux/linux.spec | grep -Ev '^Patch0123|^Patch0130' | sed -n 's/.*: //p'); do
+ for i in $(grep '^Patch' ${srcdir}/clearlinux/linux.spec | grep -Ev '^Patch0123|^Patch0130|^Patch1001' | sed -n 's/.*: //p'); do
msg2 "Applying patch ${i}..."
patch -Np1 -i "$srcdir/clearlinux/${i}"
done
+ ### Link the WireGuard source directory into the kernel tree
+ msg2 "Adding the WireGuard source directory..."
+ "${srcdir}/WireGuard-${_wrg_snap}/contrib/kernel-tree/jury-rig.sh" ./
+
local src
for src in "${source[@]}"; do
src="${src%%::*}"
@@ -333,6 +339,7 @@ sha256sums=('bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491'
'SKIP'
'7ac5c8967fb99aa379148c1edd7bc98689972fecf916e77954cd36328f85b260'
'SKIP'
+ '5aba6f0c38e97faa0b155623ba594bb0e4bd5e29deacd8d5ed8bda8d8283b0e7'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'4127910703ed934224941114c2a4e0bcc5b4841f46d04063ed7b20870a51baa0'
'b8a9225b4b5cbabac26398d11cc26566e4407d150dacb92f3411c9bb8cc23942'