summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-11-28 13:31:32 +0100
committerJosip Ponjavic2018-11-28 13:31:32 +0100
commitb4c55f91977bc6c393ba763b5aff7cbf300960d7 (patch)
tree7993959057cc81917c0b54e708c9315e4373b842
parent3a72146248f81ee6af1c43ab819bed0065def1b7 (diff)
downloadaur-b4c55f91977bc6c393ba763b5aff7cbf300960d7.tar.gz
4.19.5-2 (clr 4.19.4-664) Make lib/modules/*/vmlinuz a copy instead of a link
-rw-r--r--.SRCINFO8
-rw-r--r--90-linux.hook2
-rw-r--r--99-linux.hook2
-rw-r--r--PKGBUILD21
4 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f0a475ac780..fc5d49341a71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear
pkgver = 4.19.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/clearlinux-pkgs/linux
arch = x86_64
license = GPL2
@@ -15,7 +15,7 @@ pkgbase = linux-clear
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.sign
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.19.5.xz
- source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=4.19.4-663
+ source = clearlinux::git+https://github.com/clearlinux-pkgs/linux.git#tag=4.19.4-664
source = https://downloadmirror.intel.com/28039/eng/microcode-20180807.tgz
source = enable_additional_cpu_optimizations-20180509.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20180509.tar.gz
source = 60-linux.hook
@@ -31,8 +31,8 @@ pkgbase = linux-clear
sha256sums = 29f9e8dc27e6c9b6488cecd7fe2394030307799e511db2d197d9e6553a7f9e40
sha256sums = 226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
- sha256sums = 5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184
+ sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
+ sha256sums = 9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-clear
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/99-linux.hook b/99-linux.hook
index 036f6bf2534a..138b911b6794 100644
--- a/99-linux.hook
+++ b/99-linux.hook
@@ -1,7 +1,7 @@
[Trigger]
Type = File
Operation = Remove
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
[Action]
Description = Remove %PKGBASE% initramfs files...
diff --git a/PKGBUILD b/PKGBUILD
index 9b1cd35db9b8..25a35df90c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,10 +68,10 @@ _rev_override="n"
_major=4.19
_minor=5
_srcname=linux-${_major}
-_clr=${_major}.4-663
+_clr=${_major}.4-664
pkgbase=linux-clear
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
@@ -197,22 +197,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd ${_srcname}
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
@@ -347,8 +344,8 @@ sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'29f9e8dc27e6c9b6488cecd7fe2394030307799e511db2d197d9e6553a7f9e40'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- '5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
+ '9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
validpgpkeys=(