summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-11-06 16:15:29 +0100
committerJosip Ponjavic2019-11-06 16:15:29 +0100
commitf81ff9a713c04ac309d8eb42ea20e545985599a1 (patch)
tree76a9f61cfa2835be0873d8a26302784a7c646aaa
parent0ed63257081879d5d2b9e45baf7b0cea559f204e (diff)
downloadaur-f81ff9a713c04ac309d8eb42ea20e545985599a1.tar.gz
Port pkgdesc and docs changes from linux trunk
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37cf5d09d08e..271e4a483fdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,5 @@
pkgbase = linux-clear
+ pkgdesc = Clear Linux
pkgver = 5.3.9
pkgrel = 1
url = https://github.com/clearlinux-pkgs/linux
@@ -28,7 +29,7 @@ pkgbase = linux-clear
sha256sums = dbf4ac4b873ce6972e63b78d74ddba18f2701716163bb7f4b4fe5e909346a6e1
pkgname = linux-clear
- pkgdesc = Clearlinux kernel and modules
+ pkgdesc = The Clear Linux kernel and modules
install = linux.install
depends = coreutils
depends = kmod
@@ -39,5 +40,5 @@ pkgname = linux-clear
provides = WIREGUARD-MODULE
pkgname = linux-clear-headers
- pkgdesc = Header files and scripts for building modules for linux-clear
+ pkgdesc = Headers and scripts for building modules for the Clear Linux kernel
diff --git a/PKGBUILD b/PKGBUILD
index e65cdbfd99ba..b84660a671eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,6 +69,7 @@ _clr=${_major}.7-853
pkgbase=linux-clear
pkgver=${_major}.${_minor}
pkgrel=1
+pkgdesc='Clear Linux'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux"
license=('GPL2')
@@ -209,7 +210,7 @@ build() {
}
_package() {
- pkgdesc="Clearlinux kernel and modules"
+ pkgdesc="The $pkgdesc kernel and modules"
depends=('coreutils' 'kmod' 'initramfs')
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
@@ -241,7 +242,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for linux-clear"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
cd ${_srcname}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"