summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Orth2019-11-11 11:37:13 +0200
committerAlan Orth2019-11-11 11:37:13 +0200
commitf2c999180e7f715f8d03323214b69d232d4384be (patch)
tree36f4f6969be186a007ff7637a3e6b33033ae02b7
parent30405b0fbc82b80750712c5dc0487d98b271d44f (diff)
downloadaur-f2c999180e7f715f8d03323214b69d232d4384be.tar.gz
PKGBUILD: Explicitly specify name for kernel cmdline
This worked because it assumes the /boot directory is present. Arch changed their kernel installation to be more flexible and we can no longer assume /boot is present, which exposed this bug. See: https://www.archlinux.org/news/new-kernel-packages-and-mkinitcpio-hooks/
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 472e77432375..a986a719f5f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,7 +82,7 @@ package() {
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 vmlinuz-${pkgname} "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 vmlinuz-${pkgname}.cmdline $pkgdir/boot
+ install -Dm644 vmlinuz-${pkgname}.cmdline $pkgdir/boot/vmlinuz-${pkgname}.cmdline
msg2 "Installing modules..."
cp -r modules $pkgdir/usr/lib