summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-10-05 13:33:09 +0200
committerJosip Ponjavic2019-10-05 13:33:09 +0200
commit519bd27cd3149846c869a4010282a093bd744800 (patch)
tree3cb4af38ee19dcd27b28cfcc2f4876b6f47d379e
parent23067afe48b252d2385e83eff9a019787c58e487 (diff)
downloadaur-519bd27cd3149846c869a4010282a093bd744800.tar.gz
Sync with Arch
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fddd8396bf7..0a3b4131a3f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -175,8 +175,10 @@ build() {
_package() {
pkgdesc="Clearlinux current kernel and modules"
- depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
provides=('WIREGUARD-MODULE')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
@@ -192,6 +194,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install