summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-09-09 13:46:57 +0200
committerJosip Ponjavic2019-09-09 13:46:57 +0200
commit5a17aa98c575050ebd45d0973f803b45bf531972 (patch)
tree395ec990e8307d9b7e55ff1d63fe3a5d87c60aca
parenta0d6a47f6f8a0cd637c3028d423d729d29140218 (diff)
downloadaur-5a17aa98c575050ebd45d0973f803b45bf531972.tar.gz
5.3.0-2 (clr 5.3.0-5) sync with linux-clear
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--linux.install9
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 702c94a017ae..fad6dcb77c4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = linux-clear-current
pkgver = 5.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/clearlinux-pkgs/linux-current
arch = x86_64
license = GPL2
makedepends = bc
+ makedepends = cpio
makedepends = git
makedepends = inetutils
makedepends = kmod
makedepends = libelf
makedepends = xmlto
options = !strip
- source = https://git.kernel.org/torvalds/t/linux-5.3-rc7.tar.gz
+ source = https://git.kernel.org/torvalds/t/linux-5.3-rc8.tar.gz
source = clearlinux-current::git+https://github.com/clearlinux-pkgs/linux-current.git#tag=5.3.0-5
source = enable_additional_cpu_optimizations-20190822.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20190822.tar.gz
source = 60-linux.hook
@@ -20,7 +21,7 @@ pkgbase = linux-clear-current
source = linux.preset
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 97fb851940cde3041ea30322635c4c19db03c96d94cb590e333320d334f151b2
+ sha256sums = f2438baf7672aa86e5cc8a82beca86af4b4debe4fcce8fa8535f4e955647f906
sha256sums = SKIP
sha256sums = 8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
diff --git a/PKGBUILD b/PKGBUILD
index e9a2b5526d3d..c067993cd9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,15 +60,15 @@ _localmodcfg=
_major=5.3
_minor=0
-_srcname=linux-${_major}-rc7
+_srcname=linux-${_major}-rc8
_clr=${_major}.0-5
pkgbase=linux-clear-current
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-current"
license=('GPL2')
-makedepends=('bc' 'git' 'inetutils' 'kmod' 'libelf' 'xmlto')
+makedepends=('bc' 'cpio' 'git' 'inetutils' 'kmod' 'libelf' 'xmlto')
options=('!strip')
_gcc_more_v='20190822'
source=(
@@ -119,6 +119,7 @@ CONFIG_MODULE_COMPRESS_XZ=y|' ./.config
sed -i "s|CONFIG_RT_GROUP_SCHED=y|# CONFIG_RT_GROUP_SCHED is not set|g" ./.config
sed -i "s|# CONFIG_DELL_SMBIOS_SMM is not set|CONFIG_DELL_SMBIOS_SMM=y|g" ./.config
sed -i "s|CONFIG_MODULE_SIG_FORCE=y|# CONFIG_MODULE_SIG_FORCE is not set|g" ./.config
+ sed -i "s|# CONFIG_NET_SCH_CAKE is not set|CONFIG_NET_SCH_CAKE=m|g" ./.config
make olddefconfig
@@ -318,7 +319,7 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('97fb851940cde3041ea30322635c4c19db03c96d94cb590e333320d334f151b2'
+sha256sums=('f2438baf7672aa86e5cc8a82beca86af4b4debe4fcce8fa8535f4e955647f906'
'SKIP'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
diff --git a/linux.install b/linux.install
index bb2f675cbb05..1ce754cf823a 100644
--- a/linux.install
+++ b/linux.install
@@ -1,3 +1,12 @@
+
+post_install() {
+ echo ":: Adjust kernel command line in your bootloader to Clear Linux kernel default:"
+ echo " quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests initcall_debug"
+ echo " intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check noreplace-smp"
+ echo " page_alloc.shuffle=1 rcu_nocbs=0-64 rcupdate.rcu_expedited=1"
+ echo " rootfstype=ext4,btrfs,xfs tsc=reliable rw "
+}
+
post_upgrade() {
if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
echo "WARNING: /boot appears to be a separate partition but is not mounted."