summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2021-07-29 22:01:57 +0200
committerJosip Ponjavic2021-07-29 22:01:57 +0200
commitf4501c52719983a1d00a0e76dd5ee0d31d90b291 (patch)
treeac8acb05781b8e20ba1e719c69a1149831986423
parent448980dc9425c40b65afa12fe859869af82bb787 (diff)
downloadaur-f4501c52719983a1d00a0e76dd5ee0d31d90b291.tar.gz
5.14.0.rc3-1 (clr 5.14.0.rc3-44)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD269
2 files changed, 147 insertions, 135 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bf8be270277..809822a02441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear-current
pkgdesc = Clear Linux current
- pkgver = 5.9.0.rc8
+ pkgver = 5.14.0.rc3
pkgrel = 1
url = https://github.com/clearlinux-pkgs/linux-current
arch = x86_64
@@ -12,14 +12,14 @@ pkgbase = linux-clear-current
makedepends = libelf
makedepends = xmlto
options = !strip
- source = https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/snapshot/linux-5.9-rc8.tar.gz
- source = clearlinux-current::git+https://github.com/clearlinux-pkgs/linux-current.git#tag=5.9.0.rc7-40
- source = enable_additional_cpu_optimizations-20200615.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20200615.tar.gz
+ source = https://git.kernel.org/torvalds/t/linux-5.14-rc3.tar.gz
+ source = clearlinux-current::git+https://github.com/clearlinux-pkgs/linux-current.git#tag=5.14.0.rc3-44
+ source = more-uarches-20210616.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/20210616.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = fc5d8eae3949051d2d99c9425c234b580d7c20e816617f6cab928197ab55127a
+ sha256sums = a5dbb770c4b5f9d7a58100fc577385632d0519332b45f0169b020697d9edb1ce
sha256sums = SKIP
- sha256sums = 278fe9ffb29d92cc5220e7beac34a8e3a2006e714d16a21a0427069f9634af90
+ sha256sums = e5b449ef1cd5fef9f24f55250afc2fad85df4fd7371db666f7c7f20eff91c33d
pkgname = linux-clear-current
pkgdesc = The Clear Linux current kernel and modules
@@ -35,4 +35,3 @@ pkgname = linux-clear-current
pkgname = linux-clear-current-headers
pkgdesc = Headers and scripts for building modules for the Clear Linux current kernel
-
diff --git a/PKGBUILD b/PKGBUILD
index 5b6da9c73516..d910a0942432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,24 @@
# Contributor:
### BUILD OPTIONS
-# Set these variables to ANYTHING that is not null to enable them
+# Set the next two variables to ANYTHING that is not null to enable them
# Tweak kernel options prior to a build via nconfig
_makenconfig=
-_enable_gcc_more_v="y"
-# Optionally select a sub architecture by number if building in a clean chroot
-# Leaving this entry blank will require user interaction during the build
-# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 32.
+# Only compile active modules to VASTLY reduce the number of modules built and
+# the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+_localmodcfg=
+
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 36.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -25,46 +33,51 @@ _enable_gcc_more_v="y"
# 10. AMD Excavator (MEXCAVATOR)
# 11. AMD Zen (MZEN)
# 12. AMD Zen 2 (MZEN2)
-# 13. Intel P4 / older Netburst based Xeon (MPSC)
-# 14. Intel Atom (MATOM)
+# 13. AMD Zen 3 (MZEN3)
+# 14. Intel P4 / older Netburst based Xeon (MPSC)
# 15. Intel Core 2 (MCORE2)
-# 16. Intel Nehalem (MNEHALEM)
-# 17. Intel Westmere (MWESTMERE)
-# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Goldmont (MGOLDMONT)
-# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 21. Intel Sandy Bridge (MSANDYBRIDGE)
-# 22. Intel Ivy Bridge (MIVYBRIDGE)
-# 23. Intel Haswell (MHASWELL)
-# 24. Intel Broadwell (MBROADWELL)
-# 25. Intel Skylake (MSKYLAKE)
-# 26. Intel Skylake X (MSKYLAKEX)
-# 27. Intel Cannon Lake (MCANNONLAKE)
-# 28. Intel Ice Lake (MICELAKE)
-# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Intel Cooper Lake (MCOOPERLAKE)
-# 31. Intel Tiger Lake (MTIGERLAKE)
-# 32. Generic-x86-64 (GENERIC_CPU)
-# 33. Native optimizations autodetected by GCC (MNATIVE)
+# 16. Intel Atom (MATOM)
+# 17. Intel Nehalem (MNEHALEM)
+# 18. Intel Westmere (MWESTMERE)
+# 19. Intel Silvermont (MSILVERMONT)
+# 20. Intel Goldmont (MGOLDMONT)
+# 21. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 22. Intel Sandy Bridge (MSANDYBRIDGE)
+# 23. Intel Ivy Bridge (MIVYBRIDGE)
+# 24. Intel Haswell (MHASWELL)
+# 25. Intel Broadwell (MBROADWELL)
+# 26. Intel Skylake (MSKYLAKE)
+# 27. Intel Skylake X (MSKYLAKEX)
+# 28. Intel Cannon Lake (MCANNONLAKE)
+# 29. Intel Ice Lake (MICELAKE)
+# 30. Intel Cascade Lake (MCASCADELAKE)
+# 31. Intel Cooper Lake (MCOOPERLAKE)
+# 32. Intel Tiger Lake (MTIGERLAKE)
+# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS)
+# 34. Intel Rocket Lake (MROCKETLAKE)
+# 35. Intel Alder Lake (MALDERLAKE)
+# 36. Generic-x86-64 (GENERIC_CPU)
+# 37. Generic-x86-64-v2 (GENERIC_CPU2)
+# 38. Generic-x86-64-v3 (GENERIC_CPU3)
+# 39. Generic-x86-64-v4 (GENERIC_CPU4)
+# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL)
+# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD)
_subarch=
-# Compile ONLY used modules to VASTLY reduce the number of modules built
-# and the build time.
-#
-# To keep track of which modules are needed for your specific system/hardware,
-# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD read the database kept if it exists
-#
-# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
-_localmodcfg=
+# Use the current kernel's .config file
+# Enabling this option will use the .config of the RUNNING kernel rather than
+# the ARCH defaults. Useful when the package gets updated and you already went
+# through the trouble of customizing your config options. NOT recommended when
+# a new kernel is released, but again, convenient for package bumps.
+_use_current=
### IMPORTANT: Do no edit below this line unless you know what you're doing
-_major=5.9
+_major=5.14
_minor=0
-_rc=8
+_rc=3
_srcname=linux-${_major}-rc${_rc}
-_clr=${_major}.0.rc7-40
+_clr=${_major}.0.rc3-44
pkgbase=linux-clear-current
pkgver=${_major}.${_minor}.rc${_rc}
pkgrel=1
@@ -74,11 +87,11 @@ url="https://github.com/clearlinux-pkgs/linux-current"
license=('GPL2')
makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
-_gcc_more_v='20200615'
+_gcc_more_v='20210616'
source=(
- "https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/snapshot/${_srcname}.tar.gz"
+ "https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
"clearlinux-current::git+https://github.com/clearlinux-pkgs/linux-current.git#tag=${_clr}"
- "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
)
export KBUILD_BUILD_HOST=archlinux
@@ -89,116 +102,113 @@ prepare() {
cd ${_srcname}
### Setting version
- echo "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
### Add Clearlinux patches
- for i in $(grep '^Patch' ${srcdir}/clearlinux-current/linux-current.spec | sed -n 's/.*: //p'); do
+ for i in $(grep '^Patch' ${srcdir}/clearlinux-current/linux-current.spec | sed -n 's/.*: //p'); do
echo "Applying patch ${i}..."
patch -Np1 -i "$srcdir/clearlinux-current/${i}"
- done
+ done
### Setting config
- echo "Setting config..."
- cp -Tf $srcdir/clearlinux-current/config ./.config
+ echo "Setting config..."
+ cp -Tf $srcdir/clearlinux-current/config ./.config
### Enable extra stuff from arch kernel
- echo "Enable extra stuff from arch kernel..."
-
- # General setup
- scripts/config --enable IKCONFIG \
- --enable-after IKCONFIG IKCONFIG_PROC \
- --undefine RT_GROUP_SCHED
-
- # Power management and ACPI options
- scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
- --enable ACPI_TABLE_UPGRADE
-
- # Enable loadable module support
- scripts/config --undefine MODULE_SIG_FORCE \
- --enable MODULE_COMPRESS \
- --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ
-
- # Networking support
- scripts/config --enable NETFILTER_INGRESS \
- --module NET_SCH_CAKE
-
- # Device Drivers
- scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
- --enable DELL_SMBIOS_SMM \
- --module PATA_JMICRON \
- --enable-after SOUND SOUND_OSS_CORE \
- --enable SND_OSSEMUL \
- --module-after SND_OSSEMUL SND_MIXER_OSS \
- --module-after SND_MIXER_OSS SND_PCM_OSS \
- --enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
-
- # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
- scripts/config --enable SECTION_MISMATCH_WARN_ONLY
-
- # Security options
- scripts/config --enable SECURITY_SELINUX \
- --enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \
- --enable SECURITY_SMACK \
- --enable-after SECURITY_SMACK SECURITY_SMACK_BRINGUP \
- --enable-after SECURITY_SMACK_BRINGUP SECURITY_SMACK_NETFILTER \
- --enable-after SECURITY_SMACK_NETFILTER SECURITY_SMACK_APPEND_SIGNALS \
- --enable SECURITY_TOMOYO \
- --enable SECURITY_APPARMOR \
- --enable SECURITY_YAMA
-
- ## Library routines
- scripts/config --enable FONT_TER16x32
-
- make olddefconfig
-
- ### Patch source to unlock additional gcc CPU optimizations
- # https://github.com/graysky2/kernel_gcc_patch
- if [ "${_enable_gcc_more_v}" = "y" ]; then
- echo "Applying enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.8+.patch ..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v5.8+.patch"
- fi
+ echo "Enable extra stuff from arch kernel..."
+
+ # General setup
+ scripts/config --enable IKCONFIG_PROC \
+ --undefine RT_GROUP_SCHED
+
+ # Power management and ACPI options
+ scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
+ --enable ACPI_TABLE_UPGRADE
- ### Get kernel version
- if [ "${_enable_gcc_more_v}" = "y" ] || [ -n "${_subarch}" ]; then
+ # Enable loadable module support
+ scripts/config --undefine MODULE_SIG_FORCE \
+ --enable MODULE_COMPRESS_ZSTD
+
+ # Networking support
+ scripts/config --enable NETFILTER_INGRESS
+
+ # Device Drivers
+ scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
+ --enable DELL_SMBIOS_SMM \
+ --enable NET_VENDOR_AQUANTIA
+
+ # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
+ scripts/config --enable SECTION_MISMATCH_WARN_ONLY
+
+ # Security options
+ scripts/config --enable SECURITY_SELINUX_BOOTPARAM \
+ --enable SECURITY_SMACK_BRINGUP \
+ --enable SECURITY_SMACK_NETFILTER \
+ --enable SECURITY_SMACK_APPEND_SIGNALS \
+ --enable SECURITY_TOMOYO \
+ --enable SECURITY_APPARMOR \
+ --enable SECURITY_YAMA
+
+ # Library routines
+ scripts/config --enable FONT_TER16x32
+
+ make olddefconfig
+
+ # https://github.com/graysky2/kernel_compiler_patch
+ # make sure to apply after olddefconfig to allow the next section
+ echo "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.8+.patch"
+
+ if [ -n "$_subarch" ]; then
+ # user wants a subarch so apply choice defined above interactively via 'yes'
yes "$_subarch" | make oldconfig
+ else
+ # no subarch defined so allow user to pick one
+ make oldconfig
+ fi
+
+ ### Optionally use running kernel's config
+ # code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
+ if [ -n "$_use_current" ]; then
+ if [[ -s /proc/config.gz ]]; then
+ echo "Extracting config from /proc/config.gz..."
+ # modprobe configs
+ zcat /proc/config.gz > ./.config
else
- make prepare
+ warning "Your kernel was not compiled with IKCONFIG_PROC!"
+ warning "You cannot read the current config!"
+ warning "Aborting!"
+ exit
fi
-
- ### Prepared version
- make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ fi
### Optionally load needed modules for the make localmodconfig
- # See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -e $HOME/.config/modprobed.db ]; then
echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
+ else
echo "No modprobed.db data found"
exit
- fi
fi
+ fi
- ### do not run `make olddefconfig` as it sets default options
- yes "" | make config >/dev/null
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
- ### Running make nconfig
-
- [[ -z "$_makenconfig" ]] || make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
### Save configuration for later reuse
-
- cp -Tf ./.config "${startdir}/config-${pkgver}-${pkgrel}${pkgbase#linux}"
+ cp -Tf ./.config "${startdir}/config-${pkgver}-${pkgrel}${pkgbase#linux}"
}
build() {
cd ${_srcname}
- make -j$(nproc) bzImage modules
+ make bzImage modules
}
_package() {
@@ -257,14 +267,17 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
@@ -313,9 +326,9 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('fc5d8eae3949051d2d99c9425c234b580d7c20e816617f6cab928197ab55127a'
+sha256sums=('a5dbb770c4b5f9d7a58100fc577385632d0519332b45f0169b020697d9edb1ce'
'SKIP'
- '278fe9ffb29d92cc5220e7beac34a8e3a2006e714d16a21a0427069f9634af90')
+ 'e5b449ef1cd5fef9f24f55250afc2fad85df4fd7371db666f7c7f20eff91c33d')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds