summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-10-05 13:33:24 +0200
committerJosip Ponjavic2019-10-05 13:33:24 +0200
commit38e7e9a639ed980e49c7db65d1129a7fe8f0d91b (patch)
tree6ff74b814d5a9d3a19829cf53d3c3325a2964ee3
parent62a780267798108da6432fbe2d2c75d95dd2ee33 (diff)
downloadaur-38e7e9a639ed980e49c7db65d1129a7fe8f0d91b.tar.gz
Sync with Arch
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30900d996ca3..1f1e6c942c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -174,8 +174,10 @@ build() {
_package() {
pkgdesc="Clearlinux lts2018 kernel and modules"
- depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
provides=('WIREGUARD-MODULE')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
@@ -191,6 +193,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install