summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-11-05 13:09:35 +0100
committerJosip Ponjavic2019-11-05 13:09:35 +0100
commit4036d12b4542a61c18522bdf9f9db1b916fbeb0d (patch)
treea464f5d0c68628852ac20cdee5b3db5856c3c85b
parent516830c748a34e94c00355f668e37000d088e8bf (diff)
downloadaur-4036d12b4542a61c18522bdf9f9db1b916fbeb0d.tar.gz
4.19.81-4 (clr 4.19.79-86) enable CONFIG_NETFILTER_INGRESS
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD40
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c50f683a0b4..30c56ab80ce0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear-lts2018
pkgver = 4.19.81
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/clearlinux-pkgs/linux-lts2018
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 0b8a4bb96083..919eaa87ca71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ _srcname=linux-${_major}
_clr=${_major}.79-86
pkgbase=linux-clear-lts2018
pkgver=${_major}.${_minor}
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2018"
license=('GPL2')
@@ -108,34 +108,34 @@ prepare() {
### Enable extra stuff from arch kernel
msg2 "Enable extra stuff from arch kernel..."
+ # General setup
+ scripts/config --module IKCONFIG \
+ --enable-after IKCONFIG IKCONFIG_PROC \
+ --undefine RT_GROUP_SCHED
+
+ # Power management and ACPI options
+ scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
+ --enable HIBERNATION
+
+ # Enable loadable module support
scripts/config --undefine MODULE_SIG_FORCE \
--enable MODULE_COMPRESS \
- --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ \
+ --enable-after MODULE_COMPRESS MODULE_COMPRESS_XZ
+
+ # Networking support
+ scripts/config --enable NETFILTER_INGRESS \
+ --module NET_SCH_CAKE
+
+ # Device Drivers
+ scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER \
--enable DELL_SMBIOS_SMM \
- --module IKCONFIG \
- --enable-after IKCONFIG IKCONFIG_PROC \
+ --module PATA_JMICRON \
--enable-after SOUND SOUND_OSS_CORE \
--enable SND_OSSEMUL \
--module-after SND_OSSEMUL SND_MIXER_OSS \
--module-after SND_MIXER_OSS SND_PCM_OSS \
--enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
- # Scheduler features
- scripts/config --undefine RT_GROUP_SCHED
-
- # Queueing/Scheduling
- scripts/config --module NET_SCH_CAKE
-
- # PATA SFF controllers with BMDMA
- scripts/config --module PATA_JMICRON
-
- # Power management and ACPI options
- scripts/config --enable ACPI_REV_OVERRIDE_POSSIBLE \
- --enable HIBERNATION
-
- # Console display driver support
- scripts/config --enable FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER
-
# Security options
scripts/config --enable SECURITY_SELINUX \
--enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \