summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2020-01-23 10:54:26 +0100
committerJosip Ponjavic2020-01-23 10:54:26 +0100
commitb26e971ff3e57811dff595fe4840dc56c5d08b6d (patch)
tree2461e17f78933cb73eb187117956e1930f17634d
parentab313fe7e73442c70ad7da72e3afa7d64e8e7551 (diff)
downloadaur-b26e971ff3e57811dff595fe4840dc56c5d08b6d.tar.gz
4.19.98-1 (clr 4.19.91-101)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD48
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc6083721658..d05d5249c7bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-clear-lts2018
pkgdesc = Clear Linux lts2018
- pkgver = 4.19.97
+ pkgver = 4.19.98
pkgrel = 1
url = https://github.com/clearlinux-pkgs/linux-lts2018
arch = x86_64
@@ -14,14 +14,14 @@ pkgbase = linux-clear-lts2018
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.tar.sign
- source = https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.19.97.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.19.98.xz
source = linux-clear-lts2018::git+https://github.com/clearlinux-pkgs/linux-lts2018.git#tag=4.19.91-101
source = enable_additional_cpu_optimizations-20190822.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20190822.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1
sha256sums = SKIP
- sha256sums = 946bb4ee85bc272f32a112127620740602fa91d160d3e4d4fe7d27b5e1d4d0b8
+ sha256sums = c1cfb28e5675119cf8ac88c27ebf2a42db3059f9db5e1f6cc152cefe37e6df89
sha256sums = SKIP
sha256sums = 8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5
diff --git a/PKGBUILD b/PKGBUILD
index 8ac0f6d90143..5d60aa7968fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,7 +59,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
_major=4.19
-_minor=97
+_minor=98
_srcname=linux-${_major}
_clr=${_major}.91-101
pkgbase=linux-clear-lts2018
@@ -87,27 +87,27 @@ prepare() {
cd ${_srcname}
### Add upstream patches
- msg2 "Add upstream patches"
+ echo "Add upstream patches"
patch -Np1 -i ../patch-${pkgver}
### Setting version
- msg2 "Setting version..."
+ echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
### Add Clearlinux patches
for i in $(grep '^Patch' ${srcdir}/${pkgbase}/linux-lts2018.spec | grep -Ev '^Patch0126|^Patch0128' | sed -n 's/.*: //p'); do
- msg2 "Applying patch ${i}..."
+ echo "Applying patch ${i}..."
patch -Np1 -i "$srcdir/${pkgbase}/${i}"
done
### Setting config
- msg2 "Setting config..."
+ echo "Setting config..."
cp -Tf $srcdir/${pkgbase}/config ./.config
### Enable extra stuff from arch kernel
- msg2 "Enable extra stuff from arch kernel..."
+ echo "Enable extra stuff from arch kernel..."
# General setup
scripts/config --enable IKCONFIG \
@@ -156,7 +156,7 @@ prepare() {
### Patch source to unlock additional gcc CPU optimizations
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
- msg2 "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
+ echo "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
fi
@@ -169,16 +169,16 @@ prepare() {
### Prepared version
make -s kernelrelease > version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
+ echo "Prepared %s version %s" "$pkgbase" "$(<version)"
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ echo "Running Steven Rostedt's make localmodconfig now"
make LSMOD=$HOME/.config/modprobed.db localmodconfig
else
- msg2 "No modprobed.db data found"
+ echo "No modprobed.db data found"
exit
fi
fi
@@ -214,7 +214,7 @@ _package() {
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- msg2 "Installing boot image..."
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
@@ -222,13 +222,13 @@ _package() {
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- msg2 "Installing modules..."
+ echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -238,7 +238,7 @@ _package-headers() {
cd ${_srcname}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
+ echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
@@ -254,7 +254,7 @@ _package-headers() {
# ???
mkdir "$builddir/.tmp_versions"
- msg2 "Installing headers..."
+ echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -270,10 +270,10 @@ _package-headers() {
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
@@ -281,16 +281,16 @@ _package-headers() {
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ echo "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -bi "$file")" in
@@ -305,11 +305,11 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
+ echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
- msg2 "Fixing permissions..."
+ echo "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}
@@ -323,7 +323,7 @@ done
sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'SKIP'
- '946bb4ee85bc272f32a112127620740602fa91d160d3e4d4fe7d27b5e1d4d0b8'
+ 'c1cfb28e5675119cf8ac88c27ebf2a42db3059f9db5e1f6cc152cefe37e6df89'
'SKIP'
'8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5')