summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2020-05-29 13:59:11 +0200
committerJosip Ponjavic2020-05-29 13:59:11 +0200
commit7e537c16782dfc14af48c51d32d6f3e57377d8c6 (patch)
treef4561863236b0d7078665ff47dae7f06bb2d5b26
parentfdd5732b99ade2f052db8354505c57abb9fa016c (diff)
downloadaur-7e537c16782dfc14af48c51d32d6f3e57377d8c6.tar.gz
5.4.43-2 (clr 5.4.43-41)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 959ab3ebfb75..7db0e59509a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-clear-lts2019
pkgdesc = Clear Linux lts2019
pkgver = 5.4.43
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/clearlinux-pkgs/linux-lts2019
arch = x86_64
license = GPL2
@@ -15,15 +15,15 @@ pkgbase = linux-clear-lts2019
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.sign
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.4.43.xz
- source = clearlinux-lts2019::git+https://github.com/clearlinux-pkgs/linux-lts2019.git#tag=5.4.42-40
- source = https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/74137a6a0159825b9692866578dc64b2b7a330e8/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch
+ source = clearlinux-lts2019::git+https://github.com/clearlinux-pkgs/linux-lts2019.git#tag=5.4.43-41
+ source = enable_additional_cpu_optimizations-20200527.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20200527.tar.gz
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491
sha256sums = SKIP
sha256sums = 2685d44c357d95262ec685eb35820448575b2907f8232c32aa384e901bc5e4c4
sha256sums = SKIP
- sha256sums = 0b785030b616844da50dc0e26d24671066334937be5a6a75e76d5ac65ba02477
+ sha256sums = 8255e6b6e0bdcd66a73d917b56cf2cccdd1c3f4b3621891cfffc203404a5b6dc
pkgname = linux-clear-lts2019
pkgdesc = The Clear Linux lts2019 kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index c09a6e65be96..f0d07023e982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _enable_gcc_more_v="y"
# Optionally select a sub architecture by number if building in a clean chroot
# Leaving this entry blank will require user interaction during the build
# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 30.
+# generic (default) option is 32.
#
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
@@ -42,8 +42,10 @@ _enable_gcc_more_v="y"
# 27. Intel Cannon Lake (MCANNONLAKE)
# 28. Intel Ice Lake (MICELAKE)
# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Generic-x86-64 (GENERIC_CPU)
-# 31. Native optimizations autodetected by GCC (MNATIVE)
+# 30. Intel Cooper Lake (MCOOPERLAKE)
+# 31. Intel Tiger Lake (MTIGERLAKE)
+# 32. Generic-x86-64 (GENERIC_CPU)
+# 33. Native optimizations autodetected by GCC (MNATIVE)
_subarch=
# Compile ONLY used modules to VASTLY reduce the number of modules built
@@ -61,22 +63,23 @@ _localmodcfg=
_major=5.4
_minor=43
_srcname=linux-${_major}
-_clr=${_major}.42-40
+_clr=${_major}.43-41
pkgbase=linux-clear-lts2019
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
pkgdesc='Clear Linux lts2019'
arch=('x86_64')
url="https://github.com/clearlinux-pkgs/linux-lts2019"
license=('GPL2')
makedepends=('bc' 'cpio' 'git' 'kmod' 'libelf' 'xmlto')
options=('!strip')
+_gcc_more_v='20200527'
source=(
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.xz"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${_major}.tar.sign"
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"clearlinux-lts2019::git+https://github.com/clearlinux-pkgs/linux-lts2019.git#tag=${_clr}"
- 'https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/74137a6a0159825b9692866578dc64b2b7a330e8/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch'
+ "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
)
export KBUILD_BUILD_HOST=archlinux
@@ -138,6 +141,9 @@ prepare() {
--module-after SND_MIXER_OSS SND_PCM_OSS \
--enable-after SND_PCM_OSS SND_PCM_OSS_PLUGINS
+ # Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
+ scripts/config --enable SECTION_MISMATCH_WARN_ONLY
+
# Security options
scripts/config --enable SECURITY_SELINUX \
--enable-after SECURITY_SELINUX SECURITY_SELINUX_BOOTPARAM \
@@ -158,7 +164,7 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
if [ "${_enable_gcc_more_v}" = "y" ]; then
echo "Applying enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch ..."
- patch -Np1 -i "$srcdir/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch"
+ patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v10.1+_kernel_v4.19-v5.4.patch"
fi
### Get kernel version
@@ -317,7 +323,7 @@ sha256sums=('bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491'
'SKIP'
'2685d44c357d95262ec685eb35820448575b2907f8232c32aa384e901bc5e4c4'
'SKIP'
- '0b785030b616844da50dc0e26d24671066334937be5a6a75e76d5ac65ba02477')
+ '8255e6b6e0bdcd66a73d917b56cf2cccdd1c3f4b3621891cfffc203404a5b6dc')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds