summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2022-11-17 16:38:39 +0100
committerJosip Ponjavic2022-11-17 16:38:39 +0100
commit1b52a4077789d0ab486f080949186d6ea378d486 (patch)
treebee2ca636ecc3a2ec74bf9b20517385d0a54f3df
parent54f7e245b892976e476b367e8458affb9500bb7b (diff)
downloadaur-1b52a4077789d0ab486f080949186d6ea378d486.tar.gz
FS#76537: Fix 'file' invocation
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0415a584735e..b1444f59ec37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -358,7 +358,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)