summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2022-10-17 18:43:41 +0200
committerJosip Ponjavic2022-10-17 18:43:41 +0200
commit8bbfcd57889feed2379140c199e5083f40c8544f (patch)
tree04d35ddee39e8b802c971077d338ad3ad87dacb5
parentbe7893d37e891f1b918b5fd9c458be6b44fdf08f (diff)
downloadaur-8bbfcd57889feed2379140c199e5083f40c8544f.tar.gz
Enable NTFS3 and SMB configs
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b5775e15685..37b7460c3c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -161,6 +161,16 @@ prepare() {
# Kernel hacking -> Compile-time checks and compiler options -> Make section mismatch errors non-fatal
scripts/config --enable SECTION_MISMATCH_WARN_ONLY
+ # File systems
+ scripts/config --module NTFS3_FS \
+ --enable NTFS3_LZX_XPRESS \
+ --enable NTFS3_FS_POSIX_ACL
+
+ scripts/config --module SMB_SERVER \
+ --enable SMB_SERVER_SMBDIRECT \
+ --enable SMB_SERVER_CHECK_CAP_NET_ADMIN \
+ --enable SMB_SERVER_KERBEROS5
+
# Security options
scripts/config --enable SECURITY_SELINUX \
--enable SECURITY_SELINUX_BOOTPARAM \
@@ -238,7 +248,7 @@ _package() {
optdepends=('wireless-regdb: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(KSMBD-MODULE VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
install=linux.install
cd $_srcname