summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2023-03-18 22:00:05 +0100
committerZeioth2023-03-18 22:00:05 +0100
commit4b18b1dab600b0546879954176978bcfb93b50b4 (patch)
treeb0b61bc2fcc08af71163fbdc9ad0474079e232fb
downloadaur-4b18b1dab600b0546879954176978bcfb93b50b4.tar.gz
Now we differentiate between stable and git version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb940a5362aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = linux-command-gpt
+ pkgdesc = Get Linux commands in natural language with the power of ChatGPT.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/asrul10/linux-command-gpt.git
+ arch = any
+ license = MIT
+ makedepends = go
+ depends = go
+ provides = linux-command-gpt
+ conflicts = linux-command-gpt-git
+ source = git+https://github.com/asrul10/linux-command-gpt.git
+ sha256sums = SKIP
+
+pkgname = linux-command-gpt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35c1ec98a9b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Adrian Lopez <zeioth@hotmail.com>
+pkgname=linux-command-gpt
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Get Linux commands in natural language with the power of ChatGPT."
+arch=(any)
+url="https://github.com/asrul10/linux-command-gpt.git"
+license=('MIT')
+groups=()
+depends=(go)
+makedepends=(go)
+checkdepends=()
+optdepends=()
+provides=(linux-command-gpt)
+conflicts=(linux-command-gpt-git)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+package() {
+ # Compile
+ cd "${srcdir}"/linux-command-gpt
+ go build -o lcg
+
+ # Add it to /usr/bin to make it executable
+ sudo ln -s "${srcdir}"/linux-command-gpt/lcg /usr/bin
+}