summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2023-03-18 21:59:25 +0100
committerZeioth2023-03-18 21:59:25 +0100
commit6a8403b6d824d86be46bdba0bea7b7d9d0c8bef0 (patch)
tree8f613731b5434c3c4de39b70f3dd079dbb2d24b2
parent9591f82784bdafbf747fd121705d00e955a3193b (diff)
downloadaur-6a8403b6d824d86be46bdba0bea7b7d9d0c8bef0.tar.gz
Now we differentiate between stable and git version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 964f600cbb04..f4447e3127e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = linux-command-gpt-git
pkgdesc = Get Linux commands in natural language with the power of ChatGPT.
- pkgver = 1.0
+ pkgver = 1.0.r3.7e6ecfa
pkgrel = 1
url = https://github.com/asrul10/linux-command-gpt.git
arch = any
license = MIT
makedepends = go
depends = go
- provides = linux-command-gpt
- conflicts = linux-command-gpt-git
+ provides = linux-command-gpt-git
+ conflicts = linux-command-gpt
source = git+https://github.com/asrul10/linux-command-gpt.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2b23adbde046..7d80a868efb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Adrian Lopez <zeioth@hotmail.com>
pkgname=linux-command-gpt-git
-pkgver=1.0
+pkgver=1.0.r3.7e6ecfa
pkgrel=1
epoch=
pkgdesc="Get Linux commands in natural language with the power of ChatGPT."
@@ -17,8 +17,8 @@ depends=(go)
makedepends=(go)
checkdepends=()
optdepends=()
-provides=(linux-command-gpt)
-conflicts=(linux-command-gpt-git)
+provides=(linux-command-gpt-git)
+conflicts=(linux-command-gpt)
replaces=()
backup=()
options=()
@@ -29,6 +29,11 @@ noextract=()
sha256sums=('SKIP')
validpgpkeys=()
+pkgver() {
+ cd "${_pkgname}"
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
# Compile
cd "${srcdir}"/linux-command-gpt
@@ -36,5 +41,4 @@ package() {
# Add it to /usr/bin to make it executable
sudo ln -s "${srcdir}"/linux-command-gpt/lcg /usr/bin
-
}