aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2019-04-15 21:43:40 +0200
committerMatteo De Carlo2019-04-15 21:43:40 +0200
commitbd0dca7850ca388cb7971d5ad48269f42c0646c6 (patch)
tree616f0e4546df11d064f280db263e2d41c26bf33d
parente9f0416ac07ae2820de9e6472f54c194cef392aa (diff)
downloadaur-bd0dca7850ca388cb7971d5ad48269f42c0646c6.tar.gz
Update to 5.0.7.arch1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--config16
3 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b56cc47a4a1..6c4b6c7d2cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-covolunablu-gaming
- pkgver = 5.0.1.arch1
+ pkgver = 5.0.7.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.0.1-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.0.7-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -10,11 +10,9 @@ pkgbase = linux-covolunablu-gaming
makedepends = bc
makedepends = libelf
makedepends = git
- makedepends = python-sphinx
- makedepends = graphviz
conflicts = steamos-xpad-dkms
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.0.1-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.0.7-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -25,7 +23,7 @@ pkgbase = linux-covolunablu-gaming
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = 9aea051dda0701cef1b64a0db7cc3b27f3eea974a082473fca5b346be990c2b7
+ sha256sums = fdb355884faa86a2f9725d09657c9c32573b0f1e8bb31416823d1198bcb2f80d
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
diff --git a/PKGBUILD b/PKGBUILD
index 5722bd29585e..f8f759a2a239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# Contributor: Thomas Baechler <thomas at archlinux dot org>
pkgbase=linux-covolunablu-gaming
-_srcver=5.0.1-arch1
+_srcver=5.0.7-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
+makedepends=(xmlto kmod inetutils bc libelf git)
options=('!strip')
# Because is already included in the kernel itself, no need to use dkms.
@@ -36,7 +36,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '9aea051dda0701cef1b64a0db7cc3b27f3eea974a082473fca5b346be990c2b7'
+ '0035f06a22dc72a0804ac049212ac1e697d4eef23c526d8aae590c90bcd9a0c0'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -78,7 +78,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -229,18 +229,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
diff --git a/config b/config
index 82433d9054a6..805abfd32212 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.0.0-arch1 Kernel Configuration
+# Linux/x86 5.0.7-arch1 Kernel Configuration
#
#
@@ -9271,8 +9271,16 @@ CONFIG_SECURITY_SELINUX_BOOTPARAM_VALUE=0
CONFIG_SECURITY_SELINUX_DEVELOP=y
CONFIG_SECURITY_SELINUX_AVC_STATS=y
CONFIG_SECURITY_SELINUX_CHECKREQPROT_VALUE=0
-# CONFIG_SECURITY_SMACK is not set
-# CONFIG_SECURITY_TOMOYO is not set
+CONFIG_SECURITY_SMACK=y
+CONFIG_SECURITY_SMACK_BRINGUP=y
+CONFIG_SECURITY_SMACK_NETFILTER=y
+CONFIG_SECURITY_SMACK_APPEND_SIGNALS=y
+CONFIG_SECURITY_TOMOYO=y
+CONFIG_SECURITY_TOMOYO_MAX_ACCEPT_ENTRY=2048
+CONFIG_SECURITY_TOMOYO_MAX_AUDIT_LOG=1024
+# CONFIG_SECURITY_TOMOYO_OMIT_USERSPACE_LOADER is not set
+CONFIG_SECURITY_TOMOYO_POLICY_LOADER="/sbin/tomoyo-init"
+CONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER="/sbin/init"
CONFIG_SECURITY_APPARMOR=y
CONFIG_SECURITY_APPARMOR_BOOTPARAM_VALUE=0
CONFIG_SECURITY_APPARMOR_HASH=y
@@ -9286,6 +9294,8 @@ CONFIG_INTEGRITY_AUDIT=y
# CONFIG_IMA is not set
# CONFIG_EVM is not set
# CONFIG_DEFAULT_SECURITY_SELINUX is not set
+# CONFIG_DEFAULT_SECURITY_SMACK is not set
+# CONFIG_DEFAULT_SECURITY_TOMOYO is not set
# CONFIG_DEFAULT_SECURITY_APPARMOR is not set
CONFIG_DEFAULT_SECURITY_DAC=y
CONFIG_DEFAULT_SECURITY=""