aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2018-12-16 22:08:04 +0100
committerMatteo De Carlo2018-12-16 22:08:04 +0100
commitd294b4ad61ca8a33a054d994360c4ec07bd0cc83 (patch)
tree4a9db8d2c86ada725873a8aacca985efd9e3f6bb
parent520721bbc3c389215ae41e2a611cc0ab82b7d6d3 (diff)
downloadaur-d294b4ad61ca8a33a054d994360c4ec07bd0cc83.tar.gz
update to 4.19.8
-rw-r--r--.SRCINFO10
-rw-r--r--90-linux.hook2
-rw-r--r--PKGBUILD19
-rw-r--r--config4
4 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e2c4e6b1554..21d798e05769 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-covolunablu-gaming
- pkgver = 4.19.4.arch1
+ pkgver = 4.19.8.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.19.4-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.19.8-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -14,7 +14,7 @@ pkgbase = linux-covolunablu-gaming
makedepends = graphviz
conflicts = steamos-xpad-dkms
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.4-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.8-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -25,9 +25,9 @@ pkgbase = linux-covolunablu-gaming
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = 791f9bdf1414252bdc7bd8cd3eab6675122c485c966f31776eb32acc690071cc
+ sha256sums = 7ca1e2c6e655bc9870ee631c986922cfc798b288403ed5b4b4a0f5654baf8f92
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
+ sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
sha256sums = 834c051bfa7e94678c6c48fe13be0931f7ef6c00547e8bc3e735c318296917dd
sha256sums = 24cd09c5eea6b7de311f9ae273a784f5a2c04d47f864825da4f8c6f8cf89620e
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/PKGBUILD b/PKGBUILD
index 66782bfd90b1..53888db9d5e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Thomas Baechler <thomas at archlinux dot org>
pkgbase=linux-covolunablu-gaming
-_srcver=4.19.4-arch1
+_srcver=4.19.8-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -36,9 +36,9 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '791f9bdf1414252bdc7bd8cd3eab6675122c485c966f31776eb32acc690071cc'
+ '7ca1e2c6e655bc9870ee631c986922cfc798b288403ed5b4b4a0f5654baf8f92'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
# -- covolunablu-gaming patches --
'834c051bfa7e94678c6c48fe13be0931f7ef6c00547e8bc3e735c318296917dd'
@@ -90,22 +90,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/config b/config
index 04ff8aa2e36b..429c9d48ba71 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.3-arch1 Kernel Configuration
+# Linux/x86 4.19.8-arch1 Kernel Configuration
#
#
@@ -3566,7 +3566,7 @@ CONFIG_IEEE802154_ADF7242=m
CONFIG_IEEE802154_CA8210=m
# CONFIG_IEEE802154_CA8210_DEBUGFS is not set
CONFIG_IEEE802154_MCR20A=m
-# CONFIG_IEEE802154_HWSIM is not set
+CONFIG_IEEE802154_HWSIM=m
CONFIG_XEN_NETDEV_FRONTEND=m
CONFIG_XEN_NETDEV_BACKEND=m
CONFIG_VMXNET3=m