aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2019-10-07 20:26:12 +0200
committerMatteo De Carlo2019-10-07 20:26:12 +0200
commitf39a48f8acfcc215c154b94cd2465eff45092f92 (patch)
treebacbd6dcc8e82552256f7891def757fa1e32805c
parentfce36671e9ba92ecfc574a0ca6c24811906346f1 (diff)
downloadaur-f39a48f8acfcc215c154b94cd2465eff45092f92.tar.gz
update to version 5.3.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--config4
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c5ed2b45188..293d6e3ce4c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-covolunablu-gaming
- pkgver = 5.3.1.arch1
+ pkgver = 5.3.4.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.3.1-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.3.4-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -16,7 +16,7 @@ pkgbase = linux-covolunablu-gaming
makedepends = imagemagick
conflicts = steamos-xpad-dkms
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.3.1-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.3.4-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -27,7 +27,7 @@ pkgbase = linux-covolunablu-gaming
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = 6a70335f3e2da7c2537a45e5b1ecdeb171009167092e7485877cd2a572f1b066
+ sha256sums = c50b3794a61ea6e507fb711bf7a23ee0c61ccabd0f4114f434b13b8ad2a42535
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
@@ -38,10 +38,10 @@ pkgname = linux-covolunablu-gaming
pkgdesc = The Linux-covolunablu-gaming kernel and modules
install = linux.install
depends = coreutils
- depends = linux-firmware
depends = kmod
- depends = mkinitcpio
+ depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
+ optdepends = linux-firmware: firmware images needed for some devices
backup = etc/mkinitcpio.d/linux-covolunablu-gaming.preset
pkgname = linux-covolunablu-gaming-headers
diff --git a/PKGBUILD b/PKGBUILD
index a97291326b2c..28b1945dc1c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Thomas Baechler <thomas at archlinux dot org>
pkgbase=linux-covolunablu-gaming
-_srcver=5.3.1-arch1
+_srcver=5.3.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -39,7 +39,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '6a70335f3e2da7c2537a45e5b1ecdeb171009167092e7485877cd2a572f1b066'
+ 'c50b3794a61ea6e507fb711bf7a23ee0c61ccabd0f4114f434b13b8ad2a42535'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -87,8 +87,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
[[ $pkgbase = linux ]] && groups=(base)
- depends=(coreutils linux-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -103,6 +104,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
diff --git a/config b/config
index 739819bf069e..6a5b7f1463d2 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.3.0-arch1 Kernel Configuration
+# Linux/x86 5.3.2-arch2 Kernel Configuration
#
#
@@ -9703,7 +9703,7 @@ CONFIG_SUNRPC_GSS=m
CONFIG_SUNRPC_BACKCHANNEL=y
CONFIG_SUNRPC_SWAP=y
CONFIG_RPCSEC_GSS_KRB5=m
-# CONFIG_SUNRPC_DISABLE_INSECURE_ENCTYPES is not set
+CONFIG_SUNRPC_DISABLE_INSECURE_ENCTYPES=y
CONFIG_SUNRPC_DEBUG=y
CONFIG_SUNRPC_XPRT_RDMA=m
CONFIG_CEPH_FS=m